We can not create a new account anymore

bbogale

Registered
Aug 23, 2007
2
0
51
When we create account we get “account creation complete!!!” but the new account does not exist. We are seeing wrong request results. Can anyone give us any suggestion to the cause of the problem because currently we can’t create any more new account? Thank you!

Our version is.
WHM 10.0.0 cPanel 10.0.0-R7
RedHat Enterprise 3 i686 - WHM X v3.1.0
 

Todd Mitchell

Well-Known Member
Staff member
Nov 13, 2006
301
1
243
Houston, TX
Just a friendly note that the version of cPanel/WHM you are using is very far out of date. Feel welcome to upgrade to version 11 if you desire.
DavidG is right. This is happeneing becuase your using a version that is extremely out of date. You'll have to upgrade to cPanel 11 in order to fix the issue. Since your using an outdated version, be sure to read the upgrade checklist at http://forums.cpanel.net/showthread.php?t=66166
 

bbogale

Registered
Aug 23, 2007
2
0
51
DavidG is right. This is happeneing becuase your using a version that is extremely out of date. You'll have to upgrade to cPanel 11 in order to fix the issue. Since your using an outdated version, be sure to read the upgrade checklist at http://forums.cpanel.net/showthread.php?t=66166
Hi DavidG, Thank again for help. Based on your recommendations we are going to upgrade to cPanel 11 but my question is I know that I have to update my perl to 5.8.8 but do I need to upgrade mysql, php and apache? And if you say I have to upgrade? can I still upgread them from cPanel.:confused:

I got this info from the web but can I use this to upgrade PHP and Apache after upgrading to perl 5.8.8.
1. Login to your WHM as root;
2. Go to WHM >> Server Configuration >> Tweak Settings, scroll down to "MySQL" section, switch radio button to "5.0" and click "Save" at the bottom of the screen;
3. Open root level ssh session to your VPS and run the "/scripts/mysqlup" command, wait until installation will be completed;
4. Login to WHM as root;
5. Go to WHM >> Main >> Software >> Apache Update
6. Click on the "Load Previous Config" button (if exists);
7. Select required PHP version and PHP options that your applications may need;
8. Uncheck the "Skip Apache Build if up to date" option;
9. Click "Start build" button at the bottom of the screen and wait 15-30 minutes.

Thanks,
bogale
 
Last edited:

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Hi DavidG, Thank again for help. Based on your recommendations we are going to upgrade to cPanel 11 but my question is I know that I have to update my perl to 5.8.8 but do I need to upgrade mysql, php and apache? And if you say I have to upgrade? can I still upgread them from cPanel.:confused:

I got this info from the web but can I use this to upgrade PHP and Apache after upgrading to perl 5.8.8.
1. Login to your WHM as root;
2. Go to WHM >> Server Configuration >> Tweak Settings, scroll down to "MySQL" section, switch radio button to "5.0" and click "Save" at the bottom of the screen;
3. Open root level ssh session to your VPS and run the "/scripts/mysqlup" command, wait until installation will be completed;
4. Login to WHM as root;
5. Go to WHM >> Main >> Software >> Apache Update
6. Click on the "Load Previous Config" button (if exists);
7. Select required PHP version and PHP options that your applications may need;
8. Uncheck the "Skip Apache Build if up to date" option;
9. Click "Start build" button at the bottom of the screen and wait 15-30 minutes.

Thanks,
bogale
Those instructions encompass bringing everything up to date via the WHM interface. However, cPanel 11 does still support MySQL 4.0 and 4.1 even though both have been deprecated by the makers of MySQL. While I recommend moving to 5 to avoid delaying the inevitable upgrade, if you must stick with version 4.x, I'd recommend 4.1 over 4.0 as there appear to be fewer issues with 4.1 than 4.0 (though nothing that's a show stopper).

The lowest versions of PHP still supported are Version 4.3.11 for PHP4 and 5.0.4 for PHP5. However, I'd recommend moving to at least 4.4.7 or 5.1.6 if you must upgrade.