The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Web protect

Discussion in 'General Discussion' started by comboy, Jan 3, 2005.

  1. comboy

    comboy Registered

    Joined:
    Dec 28, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    For a few days, all directories protected with password with cpanel on all accounts doesn't work. When you enter correct pass and login it still shows that pass is wrong. Anybody experienced that ? I've checked it on few accounts, and everywhere the same.

    Regards,
    Kacper
     
  2. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    sounds like your htpasswd files might have gone missing... check your .htaccess and .htpasswd files and make sure that they exist and have the correct info in them (and that the paths are correct).
     
  3. EWD

    EWD Well-Known Member
    PartnerNOC

    Joined:
    Aug 19, 2003
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    NY
    Did you guys find a solution for this??

    I had this problem last week... rebuilt apache and the problm went away.... now it is back....

    All the ht* files are there.

    Any ideas?

    Thanks in advance for any help ;)
     
  4. nbtc971

    nbtc971 Registered

    Joined:
    Jul 27, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I realize this is an old thread but i'm having that exact problem. My web host is 100megs and they are looking into it, but its really weird. Yesterday the htaccess just stopped working. All files accounted for. Any cpanel dev know if any bugs?
     
  5. EWD

    EWD Well-Known Member
    PartnerNOC

    Joined:
    Aug 19, 2003
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    NY
    The problem I had was that I had installed mod_auth_mysql and that does not work well with basic .htaccess authentication.

    The solution I used was (thanks to contour at ev1servers forum):

    In your httpd.conf file, look for this bit...


    Code:

    Code:
    <Directory />
    Options All
    AllowOverride All
    </Directory>
    ... and change it to...


    Code:

    Code:
    <Directory />
    Options All
    AuthMySQLEnable off
    AllowOverride All
    </Directory>
    Then for each of the directories where you want MySQL authentication, either in httpd.conf or in an .htaccess file, add the line:

    AuthMySQLEnable on

    And restart httpd and you're done!


    HTH :)
     
  6. nbtc971

    nbtc971 Registered

    Joined:
    Jul 27, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Actually its weird, the other directories I have protected seem fine. Would the problem your addressing affect all web protected directories?
     
Loading...

Share This Page