The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

web statistics not updating

Discussion in 'General Discussion' started by gbh1935, Nov 15, 2009.

  1. gbh1935

    gbh1935 Active Member

    Joined:
    Jun 25, 2005
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    I have statistics set to run hourly (my server has very small load) and the threshold set for a load of 3, but my stats still are not updating for awstats. When I force a manual run from whm, they update.

    Any ideas?
     
  2. InstaCarma_Tech

    InstaCarma_Tech Well-Known Member

    Joined:
    Apr 22, 2009
    Messages:
    228
    Likes Received:
    1
    Trophy Points:
    18
    Is AwStats not updating for a single domain or the entire server?

    If Awstats are not updating for a domain then:

    1. Mostly it will be due to the load issue on the server. Please increase the value of EXTRACPUS to a value more than 1 to prevent this from happening in future.

    2. To update, please use /usr/local/cpanel/base/awstats.pl -config=”domainname” instead of /scripts/runweblogs as the second option still checks for server load.

    3. Please use /usr/local/cpanel/cpanellogd if you want to update for all domains under a particular account.

    4. Please check if the eximstats database is working perfectly as cPanel checks this database while upgrading the stats. cPanel won’t upgrade awstats if this database is corrupted. Please run the following command to repair it in such a case.

    mysqlcheck -r eximstats

    5. Please check the domlogs of the particular site if it is still not showing the latest stats.
     
  3. AndyB78

    AndyB78 Active Member

    Joined:
    Oct 7, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Romania
    I believe George said the server didn't have a load issue.

    I have the same problem myself. AWS is not updating on the entire server. I have checked the eximstats db and it's ok.

    What else should we check?

    Regards!
     
    #3 AndyB78, Nov 16, 2009
    Last edited: Nov 16, 2009
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    When you run it manually, do you have an idea of how long it takes to complete? Does it take longer than an hour? Setting it to run hourly might be a bit much.
     
  5. AndyB78

    AndyB78 Active Member

    Joined:
    Oct 7, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Romania
    This is indeed a specific setup. But this problem also occurs on normal setups (for instance when AWS is setup to run daily).

    What then? How do we "jumpstart" it?

    Regards!
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm not sure I'm following you here. Your stats are set to run every hour as well? But even if set to run normally, it doesn't complete?

    Just out of curiosity:
    What version of cPanel are you running?
    Are there any really large log files (over 2GB) located here? /usr/local/apache/domlogs/
    SuPHP enabled on the server?

    Load issues as mentioned is one problem, but another is size of the accounts and how much free space is available I would think.

    You might put in a ticket with cPanel for assistance with this, and then post back here the result or fix to help more clearly define this problem for others going forward.
     
  7. AndyB78

    AndyB78 Active Member

    Joined:
    Oct 7, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Romania
    No, my stats are setup daily. I was just saying that even with an ordinary setup we can encounter this problem.

    Anyway I believe I have found my problems:

    (1) I was indeed having some very large log files in domlogs (/usr/local/apache/domlogs); one of them was 3.5GB in size;
    (2) however even after emptying all log files above 200MB the stats were still not running due to "high load" (the high load being 2-3 on a dual core cpu).

    So in the end I have raised extracpus value in /var/cpanel/cpanel.config from 0 to 10 and restarted cpanel.

    Now the logs are running. The downside is that I've lost all logs since they've initially stopped running and until I've emptied those domlogs.

    Thanks to all that took the time to reply. I hope this helps George too and sorry I have barged in your thread.

    Best regards!
     
    #7 AndyB78, Nov 16, 2009
    Last edited: Nov 16, 2009
  8. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Via root SSH access, what is the output from the following commands?
    Code:
    # cat /usr/local/cpanel/version && echo
    # cat /etc/stats.conf
     
  9. Luchanu

    Luchanu Member
    PartnerNOC

    Joined:
    Aug 7, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I have a big problem with awstats

    Hello boyz and cpanelDON :D

    I have a big problem with stats.

    First I still use 11.24.5-STABLE_38506

    The config from stats is correct BLACHOURS none i start anyhour stats:
    ALLOWALL=yes
    BLACKHOURS=
    DEFAULTGENS=ANALOG,WEBALIZER
    allow_awstats_include=0

    The permissions are correct:
    For example:

    On cat stats.conf
    WEBALIZER-example.COM.AR=yes
    ANALOG-example.COM.AR=yes
    AWSTATS-example.COM.AR=yes

    On /home/userXX/tmp/awstats
    The last update is 11 Dec, see:
    Dec 11 00:04 awstats122009.xxxxx.com.ar.txt

    So, why last update is 11 DEC, if i run stats for this user on 15 DEC ?

    The problem that I have is for many accounts, not one, many.
    Offcourse some account its ok.
    But i dont know what happen.

    And for stat /usr/local/cpanel/3rdparty/bin/awstats.pl:
    File: `/usr/local/cpanel/3rdparty/bin/awstats.pl'
    Size: 625988 Blocks: 1232 IO Block: 4096 regular file
    Device: 802h/2050d Inode: 8413898 Links: 1
    Access: (0755/-rwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
    Access: 2009-11-05 10:49:24.000000000 -0300
    Modify: 2009-11-05 10:49:24.000000000 -0300
    Change: 2009-12-15 15:17:49.000000000 -0300


    The Statistics Software Configuration is correct, i details:

    Active Enable by default
    Awstats x

    The awstats is active, but no by default, i allways want the user it considers if it active, also no active.

    The user XXXX (for example) on cpanel > Choose logs programs > Awstats is active.

    So, why when i run runweblog user, make a proccess and when i see the stats, it doesn´t update !!
    :(

    Please help anyone
    Regards!.
     
  10. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Thank you for the detailed information; please also let us know the output of the following command, where "username" is that of the account involved:
    Code:
    # cat /var/cpanel/users/username
     
  11. Luchanu

    Luchanu Member
    PartnerNOC

    Joined:
    Aug 7, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1

    /var/cpanel/users/xxxx

    BWLIMIT=1048576000
    CONTACTEMAIL=info@xxxx.com.ar
    CONTACTEMAIL2=
    DEMO=0
    DNS=xxxxxx.com.ar
    FEATURELIST=default
    HASCGI=1
    IP=190.228.48.21
    LANG=Español
    MAXADDON=0
    MAXFTP=unlimited
    MAXLST=unlimited
    MAXPARK=0
    MAXPOP=5
    MAXSQL=unlimited
    MAXSUB=unlimited
    OWNER=package
    PLAN=package_xxxxx
    RS=x3
    STARTDATE=1220902553
    SUSPENDTIME=1225314502
    USER=xxxx


    so :( ?
    Thanks a lot for response
     
  12. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    To more accurately diagnose the issue we will need additional details and will need to be able to access the system directly for further inspection; please submit a support request so that we can take a closer look at the symptoms and stats configurations involved. When available, please PM me referencing a link to this thread and your new ticket ID number.
     
  13. Luchanu

    Luchanu Member
    PartnerNOC

    Joined:
    Aug 7, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I know the support from cpanel, but the answer for request support form is poor.
    My problem was solved, i remove the file stats, from another directory, i restart the httpd, and i run the cpanellog, and i update rrdtools from awstats.

    I dont know detailts why the problem, I only took a palliative like resolution.

    if the problem appears again next week i have a fight on strategic.

    Now and so I did, you thought the possibility of an answer than has happened to me
     
  14. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    So that I may review the precise details of resolution and follow-up internally, please let me know the ticket ID number for the support request that was submitted.
     
Loading...

Share This Page