The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webalizer from URL

Discussion in 'General Discussion' started by partsace, Oct 3, 2014.

  1. partsace

    partsace Active Member

    Joined:
    Jan 11, 2007
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    I am trying to get stats from a URL without having a customer log in every time. (I will may it password protected, so don't jump on me about that!)

    Here is what I did:

    1. cd /home/username/www or cd /home/username/public_html
    2. ln -s ../tmp/webalizer stats
    3. chown username.username stats
    4. cd ../tmp
    5. chmod 755 ./
    6. chmod 755 ./webalizer

    I did both on #1, but the one that showed any sign of life is the public_html

    I am now getting a 403 Forbidden error when trying to go to website.com/stats/

    Has webalizer been updated to the point that I can no longer do this or what am I missing?

    Scott
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Granting public access your statistics is not supported, but you should be able to view the specific error message in /usr/local/apache/logs/error_log when attempting to access the URL in your browser.

    Thank you.
     
  3. partsace

    partsace Active Member

    Joined:
    Jan 11, 2007
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    That got me close to find a solution... cPanel may not support it, but it does not mean that someone else may want to know how to find a solution to this request. So, here you go:

    To make it so you can see the stats from a URL you need to log into WHM, head to Service Configuration --> Apache Configuration --> Directory "/" Options [?] and uncheck "SymLinksIfOwnerMatch".
     
Loading...

Share This Page