The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webalizer not showing stats

Discussion in 'General Discussion' started by teck, Apr 9, 2002.

  1. teck

    teck Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    Webalizer is showing:

    Cannot find an acceptable log file for your domain.

    When running /scripts/fixwebalizer, I get:

    Log checker loaded ok..
    ==& Loading Config ....product myname adminuser basename version root engineroot engine enginepl cycle docroot access_log stats_log port RS VALIASDIR VFILTERDIR extracpus skipawstats
    ==& cpaneld(logger) 4.7 Starting (11 processor system).....
    ==& WARNING: configured processor count does not match
    ==& actual processor count (1)! Running stats programs
    ==& on this system may cause excessive load!
    ==& You should set extracpus=0 in /var/cpanel/cpanel.config
    Processing username...
    [add subdomain] username sub.domain.com
    Webalizer V2.01-06 (Linux 2.4.17) English
    Error: Can't open log file /usr/local/apache/domlogs/ftp.domain.net-ftp_log
    Complete

    Tried viewing again and same error occurs. Anyone?
     
  2. teck

    teck Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    Okay, I fixed the error with the ftp log and fixwebalizer worked fine but the error message is still showing in cpanel. Do I have to wait a night?
     
  3. awsol

    awsol cPanel Test Bitch

    Joined:
    Feb 8, 2002
    Messages:
    591
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Boston MA
    /scripts/runweblogs this will update the stats for the user you specify.
     
  4. teck

    teck Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    I forgot to mention I did do that. The error still appears :(
     
  5. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    I am getting this error now. The fixwebalizer script says it deletes any previous data.. thats not a good thing, as I don't want it to start from nothing again. Is there any other way to fix this problem?
     
  6. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Was getting that too. I ended up having to set all the logs to 644.
     
  7. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I submitted a ticket about this problem to CPanel 2 days ago.

    The domlogs directory now has the ownership of root.username where username is a customer on the server. If I chown it to root.root, it changes back to root.username after running /scripts/runweblogs. Running /scripts/fixwebalizer eliminated the &Cannot find an acceptable log file for your domain& error message so that the customer could at least see their stats but it also deleted all of the previous months stats.

    Still waiting for an answer from CPanel.
     
Loading...

Share This Page