The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webalizer Showing Wrong Account's Stats

Discussion in 'General Discussion' started by rcthost, Dec 4, 2002.

  1. rcthost

    rcthost Active Member

    Joined:
    Sep 16, 2002
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Anyone else having this problem and/or know of a fix?

    Webalizer seems to be working fine.... but for at least a few accounts that I know of stats are showing for the wrong account. The header looks normal and shows correct username but then when you look at referrers it is obviously info for another account.

    I have already tried running /scripts/fixwebalizer many times with no luck. Any help would be greatly appriciated!
     
  2. techark

    techark Well-Known Member

    Joined:
    May 22, 2002
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    are these accounts on another shared IP other than the main server IP?
     
  3. rcthost

    rcthost Active Member

    Joined:
    Sep 16, 2002
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    No they are on the main server IP.
     
  4. techark

    techark Well-Known Member

    Joined:
    May 22, 2002
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    Then I am sorry can't help you there, I had the same problem when I set up some resellers with their own shared IP but never ran accross it on the main IP.
     
  5. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    [quote:b958601b4c][i:b958601b4c]Originally posted by rcthost[/i:b958601b4c]

    Anyone else having this problem and/or know of a fix?

    Webalizer seems to be working fine.... but for at least a few accounts that I know of stats are showing for the wrong account. The header looks normal and shows correct username but then when you look at referrers it is obviously info for another account.

    I have already tried running /scripts/fixwebalizer many times with no luck. Any help would be greatly appriciated![/quote:b958601b4c]

    Check the /etc directory for webalizer.conf -- if it exists delete it.
     
  6. rcthost

    rcthost Active Member

    Joined:
    Sep 16, 2002
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Thanks! Ok it was there so I downloaded it first then deleted it. Now do I need to do anything like turn webalizer on and off or run fixwebalizer script or anything?

    Do you know why that file was causing the problem by chance?

    Thanks again I hope that fixes it!
     
  7. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    [quote:80a59dac3d][i:80a59dac3d]Originally posted by rcthost[/i:80a59dac3d]

    Thanks! Ok it was there so I downloaded it first then deleted it. Now do I need to do anything like turn webalizer on and off or run fixwebalizer script or anything?

    Do you know why that file was causing the problem by chance?

    Thanks again I hope that fixes it![/quote:80a59dac3d]

    The default webalizer.conf file points to something live /var/www/blahblahblah -- anyway, every site on the server uses the same log file -- I had this on a new server, every site had the exact same stats, referrers, etc. Once I deleted the /etc/webalizer.conf file the stats generated correctly. You can wait until your server updates the logs or run /scripts/runlogsnow to update your users stats.
     
Loading...

Share This Page