The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webalizer Won't Update

Discussion in 'General Discussion' started by NorthwindHost, Apr 8, 2003.

  1. NorthwindHost

    NorthwindHost Active Member

    Joined:
    Mar 13, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lynbrook, NY
    It seems as if cpanel will not run anymore.

    When I tried to restart webalizer, it gives me a perl re-direction error.

    Please help
     
  2. meweb

    meweb Well-Known Member

    Joined:
    Feb 10, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    I suggest you download webmin from webmin.com . The latest version supports webalizer module. You can update the webalizer manually from it as well as set schedules for updating.

    Also check cpanel crons, something might be missing.

    Also if you want to update the webalizer for a particular user manually. Use /scripts/runweblogs script and provide the username.

    Let me know if it works for you.

    Regards,
     
  3. NorthwindHost

    NorthwindHost Active Member

    Joined:
    Mar 13, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lynbrook, NY
    /usr/bin/perl: relocation error: /usr/local/cpanel/3rdparty/lib/perl/auto/RRDs/RRDs.so: undefined symbol: Perl_sv_2pv

    This is the error I get when i try to fix webalizer.

    Any clue?
     
  4. michaeln

    michaeln Member

    Joined:
    Nov 20, 2001
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
  5. NorthwindHost

    NorthwindHost Active Member

    Joined:
    Mar 13, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lynbrook, NY
  6. michaeln

    michaeln Member

    Joined:
    Nov 20, 2001
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Me too.. I wonder if that is the problem.

    Is anyone using the latest version of CPanel with the Perl 5.008 and the stats still working?
     
  7. michaeln

    michaeln Member

    Joined:
    Nov 20, 2001
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I fixed it on my server.

    I had to upgrade RRDs:

    Just run these commands in shell as root

    ------------------

    cd /

    mkdir install

    cd install

    wget http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/rrdtool-1.0.40.tar.gz

    tar -zxvf rrdtool-1.0.40.tar.gz

    cd rrdtool-1.0.40

    sh configure

    make

    cd /usr/local/cpanel/3rdparty/lib/perl/auto/RRDs/

    cp RRDs.so RRDs.so.backup

    cd /install/rrdtool-1.0.40/perl-shared/blib/arch/auto/RRDs

    cp RRDs.so /usr/local/cpanel/3rdparty/lib/perl/auto/RRDs/

    cd /usr/local/cpanel/3rdparty/lib/perl/

    cp RRDs.pm RRDs.pm.backup

    cd /install/rrdtool-1.0.40/perl-shared/

    cp RRDs.pm /usr/local/cpanel/3rdparty/lib/perl/

    ------------------

    At this points your logs will work

    If you want to finish install RRDs to your server you can type the following:

    ------------------

    cd ../

    make install

    ------------------

    - Michael
     
    #7 michaeln, Apr 10, 2003
    Last edited: Apr 10, 2003
  8. NorthwindHost

    NorthwindHost Active Member

    Joined:
    Mar 13, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lynbrook, NY
    thanks, let me try this out. =)
     
  9. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    did this work for ya?
     
  10. NorthwindHost

    NorthwindHost Active Member

    Joined:
    Mar 13, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lynbrook, NY
    I think it did =).
     
Loading...

Share This Page