Webdisk - directories not showing up - Mac OSX

thec0wboy

Registered
Jul 7, 2020
2
0
1
Canada
cPanel Access Level
Website Owner
Hello everyone,

I've created users, and followed the guide in cpanel. After downloading the configuration file, I'm able to connect on my High Sierra Mac. A directory shows up in finder, but there's no sub folders available. I setup a second account, and created a specific directory location - but the same thing happens.

All I'm trying to do is setup a local FTP folder so our automation program can easily see PDF files we are saving into one of the ftp locations. It seemed like webdisk was going to the best root, but I'm hitting brick wall after brick wall.

Any help would be greatly appreciated!
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,272
313
Houston
Hi @thec0wboy

Are you setting the document root for the user you're creating, in the Directory Path box? By default this is set to your user's custom path /public_html/username which would not by default have any folders within it.

To be sure I configured there with the public_html as the path on my MacBook and had no issues seeing folders.
 

thec0wboy

Registered
Jul 7, 2020
2
0
1
Canada
cPanel Access Level
Website Owner
Thanks for the reply. I sure have. Here's the directory location.

/public_html/orders/manual_orders/completed_orders

I also tried using this directory as well as I wasn't sure if the server name needed to be infront. Neither works.

/server1/public_html/orders/manual_orders/completed_orders

When I run the configurator, it does create the shared folder but when I open it there is nothing there at all?
 
Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,272
313
Houston
And you can confirm that within the completed orders directory there *IS* data? If so I'd suggest contacting your hosting provider as they may have some kind of customization in place and I was unable to replicate this behavior.