The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webmail and Pop mail work fine but not php mail

Discussion in 'E-mail Discussions' started by nocser, Jul 12, 2006.

  1. nocser

    nocser Member

    Joined:
    Jan 13, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I have a server. Webmail and pop mail work fine. Send and receive almost imediately. But when using cpanel formmail of any others php mail, the email or message was not send. I am sure formmail configure correctly. I have many times configuring formmail. Once submit click, it directed to the successfull page without error. But the receipients not receive any email.

    Any idea what was going wrong?

    Thanks in advance.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Check whether /etc/eximmailtrap exists. If it does, delete it and then set eximmailtrap=0 in /var/cpanel/cpanel.config
     
  3. nocser

    nocser Member

    Joined:
    Jan 13, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Jonathan Michaelson, it work now
     
  4. cchapoval

    cchapoval Member

    Joined:
    Jul 5, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    formmail

    Hi Jonathan,

    same problem: Once submit click, it directed to the successfull page without error. But the receipients not receive any email.

    I did as you said here "deleted the file and added the line" but still not working, do you have any other idea....I am new with dedi, and still not using the server only testing for now.

    Also testing MySql and PHP, I created a db, and I am able to read, delete an item on a table but i am not able to add (insert into...), any ideas gladly appreciated!!

    Tks
     
    #4 cchapoval, Jul 13, 2006
    Last edited: Jul 13, 2006
  5. cchapoval

    cchapoval Member

    Joined:
    Jul 5, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    The formmail works now fine, I had to open a trouble ticket...and is fixed now.

    But the Database problem continues, as I said, I am able to delete and read from the Database using PHP but I can NOT insert into the database using the following:

    INSERT INTO table (a,b) VALUES (1,2)

    this string is compatible with PHP 3, 4 and 5....
    Any ideas why?
     
Loading...

Share This Page