Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Webmail and reverse lookup

Discussion in 'E-mail Discussion' started by rsutc, Dec 29, 2017.

Tags:
  1. rsutc

    rsutc Well-Known Member

    Joined:
    Oct 8, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    156
    Recently, to foil a spammer who was spoofing a return address on our server, I enabled reverse PTR lookup. However, this killed Webmail. A user could sent a message through the box using a mail client, but any attempt by a user to send one through Webmail was forbidden by administrative policy. A search of the exit logs showed that the attempt to send was being foiled by a reverse lookup failure on the sender by our own box! Yet, I had disabled spam checks on outgoing mail. So...what is the problem here and how do I address it. I don't want to leave reverse lookup disabled. And yet..it cannot truly function for all domains because many share a single IP.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. rsutc

    rsutc Well-Known Member

    Joined:
    Oct 8, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    156
    That should be exim logs. Mumble mumble spell checker.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Could you confirm the specific option you enabled and how you enabled it?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. rsutc

    rsutc Well-Known Member

    Joined:
    Oct 8, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    156
    In the section of the advanced EXIM config:
    custom_begin_check_message_pre

    I put:

    require verify = reverse_host_lookup

    message = Your mail server IP address ($sender_host_address) has no reverse DNS PTR

    This has worked in the past, but this time Webmail could not work.

    Rick
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice