The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

webmail dead after 9.1.0-R52 upgrade

Discussion in 'E-mail Discussions' started by jsteel, Mar 12, 2004.

  1. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Anyone else having the problem? Our monitoring tools are going nuts trying talking to port 2095 after this upgrade.
     
  2. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    Make sure webmaild, cpaneld, and whostmgrd (not sure on the third process's exact name, grep it out of the ps waux results) are killed.

    Than restart cpanel with :


    service cpsrvd restart

    This should fix it :)
     
  3. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    We don't even see a webmaild binary on the server. Where is it?

    Also, it appears webmail is running, but whatever change was just made int his release is preventing a standard TCP check on port 2095 in HP OpenView. This is all we have ever done to verify webmail was responding and only the server that got upgraded to the noted release is now failing on those checks. Something is broken.
     
  4. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Found the webmaild binary. Here's what happened when we tried to restart it:

    /usr/local/cpanel/webmaild restart
    Segmentation fault (core dumped)

    Not good at all.
     
  5. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Something is severely wrong. Opening a ticket. Everyone be forwared. Here's a cPanel restart on a non-upgraded server:

    Stopping cPanel services: [ OK ]
    Stopping webmail services: [ OK ]
    Stopping pop3 services: [ OK ]
    Stopping cPanel log services: [ OK ]
    Stopping cPanel Chat services: [ OK ]
    Stopping Melange Chat services: [ OK ]
    Stopping InterChange services: [FAILED]
    Stopping cPanel ssl services: [ OK ]
    Stopping Web Host Manager services: [ OK ]

    Stopping mailman services: Shutting down Mailman's master qrunner

    Starting eximstats: [ OK ]
    Starting cPanel services: [ OK ]
    Starting WebMail services: [ OK ]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services: [ OK ]
    Starting Melange Chat services: [ OK ]
    Starting cPanel ssl services: [ OK ]
    Starting Web Host Manager services: [ OK ]
    Starting mailman services: Starting Mailman's master qrunner.


    And now on the upgraded server:

    Stopping cPanel services: [ OK ]
    Stopping pop3 services: [ OK ]
    Stopping cPanel log services: [ OK ]
    Stopping cPanel Chat services: [ OK ]
    Stopping Melange Chat services: [ OK ]
    Stopping InterChange services: [FAILED]
    Stopping cPanel ssl services: [ OK ]

    Stopping mailman services: Shutting down Mailman's master qrunner

    Starting eximstats: [ OK ]
    Starting cPanel services: [ OK ]
    Starting cPanel Log services: [ OK ]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services: [ OK ]
    Starting Melange Chat services: [ OK ]
    Starting cPanel ssl services: [ OK ]
    Starting mailman services: Starting Mailman's master qrunner.


    Note that WebMail restarting is not part of the upgraded server.
     
    #5 jsteel, Mar 12, 2004
    Last edited: Mar 12, 2004
  6. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    That's because webmail is now part of "cPanel Services"

    Is webmail still not working for you?
     
  7. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Nope. Also noted that R57 was just released moments ago so we just upgraded to that and the same problem exists. There is no webmaild running in the list of processes and port 2095 doesn't respond to standard TCP queries for monitoring purposes.

    Exactly what does the 'Cpanel Services' entail? Did I miss a posting about this change?
     
  8. erwinfa

    erwinfa Well-Known Member

    Joined:
    Jun 14, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    9.1.0-STABLE_60 right now ....
     
  9. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Okay I see in the change log the migration of webmaild into cpsrvd. Now to just figure out what ramifications this is having on our monitoring. Is port 2095 going away?
     
  10. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Make that R61 now. We've had three releases put out in 1 hour. Sounds like a major quality control issue going on here.
     
  11. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    We've discovered that port 2096 (Webmail SSL) is responding to tCP queries just fine, but 2095 is not. Very odd.
     
  12. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    QA isn't a long as we'd like it to be due to the security fix :(
     
  13. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Very odd since 2096 just forwards to 2095+ssl
     
  14. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Very odd indeed, but that's the same way cPanel and WHM have been for over a year, and so now that you lumped Webmail into the same core (cpsrvd), it has the issue now as well). Something in the standard protocol response via TCP queries just doesn't seem to be kosher.
     
  15. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    FREEBSD 4.8 and now have cpanel,webmail and cpsrvd
    all failed. Tried stable, release and current.

    Nick, what is need to get these services back up?

    Also, why is FREEBSD bundeled with outdated MySQL versions?

    mysql-client-4.0 (4.0.15) is newer then requested version 4.0.10. (no installed needed)
    mysql-server-4.0 (4.0.15) is newer then requested version 4.0.10. (no installed needed)
     
    #15 easyhoster1, Mar 12, 2004
    Last edited: Mar 12, 2004
  16. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    From whmnews:

    Attention FreeBSD users After updating to the 9.1.x builds, you may need to manually kill whostmgrd,cpaneld,and webmaild so cpsrvd can bind to the their respective ports. You can do this by running "killall -9 whostmgrd cpaneld webmaild" in a shell or a reboot. (Note: if you don't have a problem after upgrading then you do not need to do this)
     
  17. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Reboot fixed it..you can close ticket# 42730

    Thanks Nick
     
  18. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Nick, I see the Oscommerce bug is still not fixed and was told it would be?

    Ticket# 39968
     
  19. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    The same error...

    I upgrade to an stable version... and always is the same problem with the mail... I try to restart services... but I not a linux user... my server is in linux redhat 7.3... when I try to restart cpsrvd an error says this service dont exist... please help...

    cpsrvd failed @ Fri Mar 12 06:43:23 2004. A restart was attempted automagicly.
     
  20. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Re: The same error...

    service cpanel restart
     
Loading...

Share This Page