The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

webmail.domain redirecting to https URL

Discussion in 'E-mail Discussions' started by manish294, Oct 21, 2016.

Tags:
  1. manish294

    manish294 Member

    Joined:
    Jul 5, 2016
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    After upgrading cpanel suddenly webmail URLs i.e http://webmail.domain are started redirecting to https://webmail.domain and as there is no SSL installed on webmail.domain they are showing security warnings on browser.

    Can anyone help me sorting out this issue ?

    Previously, http://webmail.domain was working fine and was not redirecting to https URL.

    Please help.

    Cpanel version is WHM 58.0 (build 32)
     
    #1 manish294, Oct 21, 2016
    Last edited by a moderator: Oct 24, 2016
  2. cPLevey

    cPLevey Technical Analyst Supervisor
    Staff Member

    Joined:
    Dec 3, 2015
    Messages:
    44
    Likes Received:
    8
    Trophy Points:
    83
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hey @manish294

    Check WHM's Tweak Settings (Home »Server Configuration »Tweak Settings) [Redirection].

    Is the "Always redirect to SSL [?]" currently set to On or Off?

    Also, does this effect all domains on the server or only a specific domain/account?
     
  3. manish294

    manish294 Member

    Joined:
    Jul 5, 2016
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi David,

    "Always redirect to SSL [?]" currently set to On or Off?

    This option is enabled on my server was I want to redirect domain/cpanel, domain/webmail to our hostname URL i.e https://hostname:2087.

    It does effect on all domains on the server. In fact my other server also have same issue.

    Thanks :)
     
  4. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    543
    Likes Received:
    39
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    There is ssl redirection setting in WHM.

    WHM > Server Configuration > Tweak Settings > Redirection tab:

    You can set ssl redirection to server hostname so that http://webmail.domain will redirect to server.hostname:2096
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,296
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @manish294,

    Check to see if "Require SSL" is enabled in the Security section of the "WHM >> Tweak Settings" interface. This forces the use of SSL when enabled.

    Thank you.
     
  6. manish294

    manish294 Member

    Joined:
    Jul 5, 2016
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi cPanelMichael,

    I have disabled the "Require SSL" from tweak settings but still webmail.domain is redirecting to the https URL :(
     
  7. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    543
    Likes Received:
    39
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    If you have disabled the "Require SSL" from tweak settings and still redirecting to the https so might be there is browser cache. Try to access after clearing browser cache or another browser and let me know the result.
     
  8. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    404
    Likes Received:
    2
    Trophy Points:
    143
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Twitter:
    ssl related settings are the above 2 and normally taking care of that should fix your issue. May be a cpanel restart and Apache restart will be good to clear of the cache and see if that helps
     
  9. manish294

    manish294 Member

    Joined:
    Jul 5, 2016
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi SysSachin,

    Yes, it was cache. Now its working fine.

    Thanks to all :) for helping me.
     
    cPanelMichael likes this.
  10. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    404
    Likes Received:
    2
    Trophy Points:
    143
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Twitter:
    glad you got things fixed :)
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,296
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
Loading...

Share This Page