The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webmail error - Fatal error: Allowed memory size of 8388608 bytes exhausted (tried t

Discussion in 'E-mail Discussions' started by Cash, Feb 29, 2008.

  1. Cash

    Cash Well-Known Member

    Joined:
    Jun 9, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Dear Sir,

    Today When I access to my webmail, i saw:


    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 4097 bytes) in /usr/local/cpanel/base/3rdparty/squirrelmail/functions/imap_general.php on line 92

    May I know how to fix it?

    My php.ini memory is already set to 64M
     
  2. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    bump up the memory in the whm tweaks for cpanel process see if that helps
     
  3. Cash

    Cash Well-Known Member

    Joined:
    Jun 9, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    I update to 256M, but still same problem.
     
  4. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    did you restart cpanel ?
     
  5. tom5599

    tom5599 Registered

    Joined:
    May 15, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I have a client getting a similar error message when she tries to send an attachment using Horde.

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 1072512 bytes) in /usr/local/cpanel/base/horde/lib/Horde/MIME/Part.php on line 1027

    Other error

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 456453 bytes) in /usr/local/cpanel/3rdparty/lib/php/Net/SMTP.php on line 788

    One attachment was 1 meg and the other was 162kb.

    I looked under tweaks and did not see a line to increase the memory can you tell me which line I should increase.

    Just as a note...she can send attachments using squirrel mail but not Horde in Horde she gets the error messages.

    Any help is greatly appreciated.

    Tom
     
  6. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    what memory limit do you see in:
    /usr/local/cpanel/3rdparty/etc/php.ini


    Try increasing that and then restart cpanel.
     
  7. tom5599

    tom5599 Registered

    Joined:
    May 15, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    It was showing 8M, I increased that to 32M and increase the timeout setting to 60sec from 30sec.

    All is working fine now!!

    THANK YOU VERY MUCH!!!

    Tom
     
  8. Bailey

    Bailey Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    120
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Wisconsin
    However, won't that be overwritten with the next cPanel update? e.g., tonight?

    :D Bailey
     
  9. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Did you found the fix.

    It doesn't matter what memory settings we use (128M, 256M, 512M)
    the message

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 34868133 bytes) in /usr/local/cpanel/3rdparty/lib/php/Net/SMTP.php on line 824

    occurs if the attachment is bigger than about 10MB.
     
  10. lsteacker

    lsteacker Registered
    PartnerNOC

    Joined:
    Sep 23, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am bumping this because I am having the same problem. All the php.ini files I look in have the limit set to 128MB. Changing it doesn't fix anything. Anyone have a solution for this one?
     
  11. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Where are you encountering this problem? The webmail interface? Somewhere in the cPanel interface? On a script you uploaded to your Apache server?

    Are you on a VPS or a dedicated server?
     
  12. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Both the SMTP and MIME PEAR modules used by Horde have flaws that cause them to consume insane amounts of memory. The only reliable workaround found is to modify the SMTP and MIME modules, setting the memory limits directly within them.
     
  13. firesprite

    firesprite Registered

    Joined:
    Sep 23, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    kiev
    solve problem

    easy way to solve thit problem is little code to you .htaccess file :
    php_value memory_limit 300M
     
  14. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Keep in mind that webmail clients are served via cpsrvd, not Apache. As a result, creating a .htaccess file would be ineffective. For webmail clients, you can edit the php.ini for that webmail client if you desire. Usually the path to a webmail application is /usr/local/cpanel/3rdparty/etc/{APPNAME}/ and inside that directory you can create a php.ini file (if one does not already exist).
     
  15. lehels

    lehels Well-Known Member

    Joined:
    Jul 10, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    The same situation we are experiencing after downgrade from Release to Stable. There is a php.in in horde/ folder with memory_limit 256M, but does not take any effect -
    Fatal error: Out of memory (allocated 92274688) (tried to allocate 28331723 bytes) in /usr/local/cpanel/3rdparty/lib/php/Net/SMTP.php on line 836 -

    Any to suggest a possible solution [?].

    Thanks,
    Lehel
     
  16. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please refer to this earlier post: cPanel Forums - View Single Post

     
  17. huafeihua116

    huafeihua116 Registered

    Joined:
    Apr 12, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    How to do that!
     
  18. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    If referring to the memory limits defined in a PHP configuration file, the files named "php.ini" may be modified using any command-line text editor (e.g., vi, vim, nano, pico); here are two commands you may use to locate the current value:
    Code:
    # grep -i "^memory_limit" /usr/local/cpanel/3rdparty/etc/php.ini
    # grep -i "^memory_limit" /usr/local/cpanel/3rdparty/etc/horde/php.ini
    Here is an example of the command-line output from the above examples and in this case there is a PHP memory limit of 128MB defined as "128M"; the 8MB reference I am seeing only in a descriptive comment on the same line:
    Code:
    # grep -i "^memory_limit" /usr/local/cpanel/3rdparty/etc/php.ini
    memory_limit = 128M			; Maximum amount of memory a script may consume (8MB)
    # grep -i "^memory_limit" /usr/local/cpanel/3rdparty/etc/horde/php.ini
    memory_limit = 128M			; Maximum amount of memory a script may consume (8MB)
     
    #18 cPanelDon, Apr 28, 2010
    Last edited: Apr 28, 2010
  19. lehels

    lehels Well-Known Member

    Joined:
    Jul 10, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Still not good

    The result is the same,

    I configured 256M in 3 php.ini-s [/usr/local/cpanel/3rdparty/etc/php.ini + roundcube/php.ini horde/php.ini], - anyway the main php.ini after cpanel restart - resets to 128M, even added
    ini_set('memory_limit','256M'); in SMTP.php + mime.php .

    The same error occurs [horde]:

    Fatal error: Out of memory (allocated 92274688) (tried to allocate 28331707 bytes) in /usr/local/cpanel/3rdparty/lib/php/Net/SMTP.php on line 836

    cPanel 11.25.0-S44718 - WHM 11.25.0 - X 3.9
    CENTOS 5.4 x86_64 standard on serverXXX

    So wherefrom is this 88MB coming - 92274688 bits /same length as my above test?

    Roundcube - remains in "Sendind message" status, and has almost the same /Out of memory/ according to the error_log:

    [04-May-2010 09:02:23] PHP Fatal error: Out of memory (allocated 105906176) (tried to allocate 28331323 bytes) in /usr/local/cpanel/base/3rdparty/roundcube/program/lib/Net/SMTP.php on line 887
    [04-May-2010 09:07:30] PHP Fatal error: Out of memory (allocated 105906176) (tried to allocate 28331329 bytes) in /usr/local/cpanel/base/3rdparty/roundcube/program/lib/Net/SMTP.php on line 887

    The only working Webmail is SquirrelMail.
    Any other hints to rewrite the memory_limit [?] or to make those other 2 webmails working with ~10MB attached files?

    Regards,
    Lehel
     
  20. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Regarding Roundcube, I believe the issue may be alleviated in a recent Beta version from the upstream vendor; the following is the applicable change log entry and reference to the related bug report that includes verbose details:
    Change Log – Roundcube Webmail
     
Loading...

Share This Page