The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webmail no loading in ssl mode

Discussion in 'E-mail Discussions' started by Bluexnet2, Aug 19, 2004.

  1. Bluexnet2

    Bluexnet2 Active Member

    Joined:
    Dec 4, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Hi, i need some help about webmail, if i try to use it in port 2095 it loads ok, but if i want to use the port 2096 it show me the 3 webmail options, but if i click in them the page never loads.

    I hope someone can help me to fix this problem, my cpanel version is WHM 9.4.0 cPanel 9.4.1-S65 in a box with RedHat Enterprise 3.

    Thank you
    Carlos
     
  2. exodux

    exodux Well-Known Member

    Joined:
    Apr 12, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brisbane, Queensland, Australia
    Login to root through SSH and run the /scripts/fixwebmail script.
    See how you go with that.
     
  3. Bluexnet2

    Bluexnet2 Active Member

    Joined:
    Dec 4, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for your response, that script give me this error:

    Code:
    /scripts/fixwebmail
    chown: failed to get attributes of `/usr/local/etc/cpanel/base/webmail/data': No such file or directory
    chmod: failed to get attributes of `/usr/local/etc/cpanel/base/webmail/data': No such file or directory
    
    There are any other way to fix this?

    Carlos.
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    i do not think that file named "/usr/local/etc/cpanel/base/webmail/data" exists in a C-panel server. The path to c-panel base is "/usr/local/cpanel/base/webmail".

    are your secure WHM/C-panel access working at port 2087 and 2083 ? the link for securewebmail shld be
    ================
    https://ip:2096
    ================
    remember to have the https when using the 2096/2087/2083.
     
  5. Bluexnet2

    Bluexnet2 Active Member

    Joined:
    Dec 4, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Hi linux-image, yes whm and cpanel works ok in 2083 and 2087 ports, the webmail is working too in the correct port with https (2096), in fact, i have to automatic log in in the secure connection using http://domain/webmail, i can see the first screen to select the webmail you want to use, change password and such, but the problem is when i select some of them and try to see the inbox, the email list never download, the site shows blank page and kepp downloading but never show the results, in the account i'm testing there are about 20 emails and all shows normal and with normal speed in the port 2095.

    Locating webmail i can see the files are in "/usr/local/cpanel/base/webmail" as you said, so maybe is a typo in the script? you think if i change the script manually the problem can be fixed?

    Thank you in advanced for your help.

    Carlos
     
  6. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    there is no file/folder with the name " /usr/local/etc/cpanel/base/webmail/data" or /usr/local/cpanel/base/webmail/data that the script is trying to correct. hence running the script will not help much.

    the https authentication is usually run by the stunnel for c-panel; and since the error is shown only when data transfer using stunnel is done; you can try a stunnel restart.

    do the following:
    ===============
    ps ax | grep stunnel
    ===============

    you will get a pid for the current running stunnel. Kill it via:
    ===============
    kill -9 pid
    ===============

    now start stunnel: /usr/local/cpanel/etc/init/startstunnel
    ==============================================
    then restart exim and cpanel via the "/etc/rc.d/init.d/" start/stop directives.

    you can try these and see for any change...
     
  7. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    Just encountered this issue

    We have encountered the same issue. Actually, it appears to be more widespread than just webmail connections, because we have also found phpmyadmin connections to get stuck.

    We believe that this situation is somehow connected to how cPanel is handling ssl (https) connections. We tried restarting stunnel, as outlined above, and then restarting exim and cpanel. This does not work, at least not consistently or permanently.

    We have found a temporary workaround, which is to change the URL that your browser is attempting to connect to. If you are trying to connect to:

    https://yourdomain.com:2096/horde/index.php, change it to:
    http://yourdomain.com:2095/horde/index.php

    This also works if you are connecting through cPanel:

    https://yourdomain.com:2083/horde/index.php, change it to:
    http://yourdomain.com:2082/horde/index.php.

    Can anyone suggest a permanent fix to this problem? In addition to the stunnel restart, we have tried updating WHM/cPanel (/scripts/upcp --force) and fixing webmail (/scripts/fixwebmail), which BTW returns the same error that has been mentioned in another thread (chown: failed to get attributes of `/usr/local/etc/cpanel/base/webmail/data': No such file or directory), so that may be related, or it may be a totally different issue.

    We did notice that when we restart cPanel, Interchange services always show as failed, but we don't know if that's related.

    We are running WHM 9.9.7 cPanel 9.9.8 S6 on RHE.

    Any help would be appreciated.
     
  8. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    If anyone is interested, the fix for this situation is to turn OFF "When users access /cpanel or /whm or /webmail on their domain redirect them to the https(ssl) port instead of the insecure one" in Tweak Settings. You should be able to turn this on, but at least in this version (9.9.7 / 9.9.8 S6), it doesn't work properly.

    Between this issue and the spamassassin problems, I don't really know how they can call this a STABLE release?
     
Loading...

Share This Page