The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

webmail proxydomains not working, always redirects to 2096

Discussion in 'E-mail Discussions' started by Xipher, Nov 26, 2013.

  1. Xipher

    Xipher Member

    Joined:
    Mar 22, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    No idea whats going on here, I've read endless threads and articles about this and found no single person who's resolved the problem.

    I run '/scripts/proxydomains add'

    "No changes needed" after every domain

    check the DNS, all the entries are there, check the httpd.conf, all the entries are there, modproxy works fine, but it ALWAYS redirects to port 2096 no matter if I use the server's domain, or if I use another domain on the server.

    What am I doing wrong here?

    Code:
    <VirtualHost 1.2.3.4:80 127.0.0.1:80 *>
        ServerName servername.domain.net
    
        ServerAlias cpanel.* whm.* webmail.* webdisk.* autodiscover.* autoconfig.*
    
        DocumentRoot /usr/local/apache/htdocs
        ServerAdmin me@domain.net
        <IfModule mod_suphp.c>
            suPHP_UserGroup nobody nobody
        </IfModule>
        RewriteEngine On
        <IfModule core.c>
            SSLProxyEngine On
        </IfModule>
        RewriteCond %{HTTP_HOST} ^cpanel\.
        RewriteCond %{HTTPS} on
        RewriteRule ^/(.*) https://127.0.0.1:2083/$1 [P]
        RewriteCond %{HTTP_HOST} ^webmail\.
        RewriteCond %{HTTPS} on
        RewriteRule ^/(.*) https://127.0.0.1:2096/$1 [P]
        RewriteCond %{HTTP_HOST} ^whm\.
        RewriteCond %{HTTPS} on
        RewriteRule ^/(.*) https://127.0.0.1:2087/$1 [P]
        RewriteCond %{HTTP_HOST} ^webdisk\.
        RewriteCond %{HTTPS} on
        RewriteRule ^/(.*) https://127.0.0.1:2078/$1 [P]
        RewriteCond %{HTTP_HOST} ^cpanel\.
        RewriteRule ^/(.*) http://127.0.0.1:2082/$1 [P]
        RewriteCond %{HTTP_HOST} ^webmail\.
        RewriteRule ^/(.*) http://127.0.0.1:2095/$1 [P]
        RewriteCond %{HTTP_HOST} ^whm\.
        RewriteRule ^/(.*) http://127.0.0.1:2086/$1 [P]
        RewriteCond %{HTTP_HOST} ^webdisk\.
        RewriteRule ^/(.*) http://127.0.0.1:2077/$1 [P]
    
        RewriteCond %{HTTP_HOST} ^autodiscover\.
        RewriteRule ^[^?]*(\?.*)? http://127.0.0.1/cgi-sys/autodiscover.cgi [P]
        RewriteCond %{HTTP_HOST} ^autoconfig\.
        RewriteRule ^[^?]*(\?.*)? http://127.0.0.1/cgi-sys/autoconfig.cgi [P]
    
        UseCanonicalName Off
    </VirtualHost>
    
    Code:
    Always redirect to SSL: OFF
    Non-SSL redirect destination: Hostname
    SSL redirect destination: Hostname
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    WHM » Server Configuration » Tweak Settings, Redirection tab
    Change this:
    Always redirect to SSL: OFF
    To this:
    Always redirect to SSL: ON
     
  3. Xipher

    Xipher Member

    Joined:
    Mar 22, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    This option is already off as per the bottom of my post
     
  4. Xipher

    Xipher Member

    Joined:
    Mar 22, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Whoops, early morning reading, however I've also turned that option on to no effect sadly.
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Just for fun, try another browser. Probably of no help here but it can't hurt.
     
  6. Xipher

    Xipher Member

    Joined:
    Mar 22, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Did try that as well :C Chrome, Firefox, IE across 3 computers and a phone, and 4 different connections at 4 different locations, put up a new domain on the server and tried that, also just did an easyapache build for the latest version of php, and that didn't work any magic either, not that I thought it would.

    Its really strange because if I Google the issue, tons of people seem to have the problem, tons more say it works fine, and nobody I've found has posted anything to say "I fixed it!".
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Let's take this to a whole other level then shall we? :)

    From within WHM, top right corner is a Support menu. On it a link to "Contact cPanel" please use that link to open a ticket. And, if you would be so kind, post back that new ticket ID here so I can follow it with you. Let's get this fixed for you.


    Thanks in advance!
     
  8. Xipher

    Xipher Member

    Joined:
    Mar 22, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Can do, all done! Sorry I've been a bit slow to respond, another busy day at work!

    Ticket ID is 4407077
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks. Please update the ticket properly to keep it moving. This is a holiday week.
     
Loading...

Share This Page