The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webmail redirects to defaultwebpage.cgi after easyapache upgrade

Discussion in 'E-mail Discussions' started by LordLiverpool, May 4, 2017.

  1. LordLiverpool

    LordLiverpool Active Member

    Joined:
    Dec 27, 2014
    Messages:
    44
    Likes Received:
    6
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hello cPanel

    Today I upgraded EasyApache3 to EasyApache4.

    Then one of my customers said their Webmail was inaccessible.

    A coincidence????

    http://webmail.domain.tld

    is redirecting to

    http://webmail.domain.tld/cgi-sys/defaultwebpage.cgi

    Email is accessible via WHM > cPanel
    Email is accessible via the 2096 port i.e: nnn.nnn.nnn.nnn:2096.

    I've checked it's the same for all domains on my VPS.
    I've checked the DNS zones, they're all appear to be unaltered.
    I've tried restarting Apache.
    I've tried gracefully rebooting my VPS.

    But the issue persists.

    Can anyone please help?

    Sorry.jpg
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,620
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What happens when you go to domain.com/webmail?
     
  3. LordLiverpool

    LordLiverpool Active Member

    Joined:
    Dec 27, 2014
    Messages:
    44
    Likes Received:
    6
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Bingo! It works!!! :)

    domain.com/webmail redirects to domain.com:2096 (I can live with that.)

    What's important is I can see the Webmail Login and I can login and access the email.

    Thank you very much.

    Webmail.jpg
     
    Infopro likes this.
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,620
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Back to business then. :)
     
  5. LordLiverpool

    LordLiverpool Active Member

    Joined:
    Dec 27, 2014
    Messages:
    44
    Likes Received:
    6
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    When I saw your suggestion, this was my reaction:

    homer-computer-doh.jpg
     
    Infopro likes this.
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,620
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    It is Friday though, so there's that. :-p
     
    LordLiverpool likes this.
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,163
    Likes Received:
    1,294
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This is likely related to the use of a custom Apache template. You can look for files named .local in the following directory to see if that's the case on your system:

    /var/cpanel/templates/apache2_4/

    You may want to remove or move the .local files in this directory out of the way until you have a chance to compare them with the updated default templates stored in this directory. Once you do that, you can run "/scripts/rebuildhttpdconf" and access to webmail.domain.tld should work again.

    Thank you.
     
    Infopro likes this.
  8. LordLiverpool

    LordLiverpool Active Member

    Joined:
    Dec 27, 2014
    Messages:
    44
    Likes Received:
    6
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    @cPanelMichael

    Thanks for replying!

    I looked in /var/cpanel/templates/apache2_4/

    But couldn't see any .local files (see screenshot below)

    I also looked in apache1, apache2, dovecot2.2 and dovecotSNI but there were no .local files in them either.

    Cheers

    cPanel01.JPG
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,163
    Likes Received:
    1,294
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You may also want to browse to the "Domains" tab in "WHM >> Tweak Settings" to verify the "Proxy Subdomains" feature is enabled. If so, and if the issue persists, feel free to open a support ticket using the link in my signature so we can take a closer look.

    Thank you.
     
  10. LordLiverpool

    LordLiverpool Active Member

    Joined:
    Dec 27, 2014
    Messages:
    44
    Likes Received:
    6
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    @cPanelMichael

    Once again thanks for replying, I'm grateful for your help.

    OK so I tweaked subdomains as you told me:

    01 Tweak Sub Domains.JPG

    Now when I goto: domain.tld/webmail for a split second I see this screen, before the usual webmail login screen:

    01 Extra Screen.jpg

    However if I go to webmail.domain.tld then I don't see the extra screen.

    Any ideas why?

    Cheers.
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,163
    Likes Received:
    1,294
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    That is the "Connection Selection" page. It will appear to visitors who navigate to a site that is experiencing a connection or firewall problem (ports 2095 or 2096). It doesn't happen when using the proxy subdomain URL because proxy subdomains use ports 80 or 443.

    Thank you.
     
Loading...

Share This Page