Webmail - sending issues

PDW

Well-Known Member
Dec 29, 2003
138
3
168
I have done some replies to similar issues tonight, but here is my full issue and problem.

I have been going through all the posts and tried pretty much all of them regarding this
error I am getting from squirellMail and Horde, I dont get any error from Roundcube it just doesn't send. Logging in is ok, but sending mail doesn't work:

SquirellMail error -
Authentication failed
535 Incorrect authentication data

Horde error -
There was an error sending your message: authentication failure [SMTP: Invalid response code received from server (code: 535, response: Incorrect authentication data)]

The Email log states:
2009-02-23 21:53:54 fixed_login authenticator failed for localhost [127.0.0.1]: 535 Incorrect authentication data ([email protected])

I am using the following -
cPanel 11.24.7-E34209 - WHM 11.24.4 - X 3.9
CENTOS 5.2 i686 on standard
PHP 5.2.4
APF firewall

I have done the following with no change no results:
Went down to stable version of Cpanel

Checked folder permissions of test domain user/etc/ user/etc/domainname/ user/etc/domainname/shadow

Checked user group and owner of said folder

Force updated exim

ran fixeverything

checked for demo accounts - none and disabled
Turned smtp tweak off, tested, turned it back on tested.
Changes users password
/scripts/mailperm
Confirmed entry in /etc/localdomains

The only thing that did do anything -
In SquirellMail /usr/local/cpanel/base/3rdparty/squirrelmail/config/config.php
changed $useSendmail = false;
Change it to true and was then able to send out email from that program, but nothing works for the other programs.

Any other suggestions?
 

PDW

Well-Known Member
Dec 29, 2003
138
3
168
2 more trouble shooting things done that led to a few other questions.

Ran /scripts/fixwebmail

chmod: cannot access `/usr/local/etc/cpanel/base/webmail/data': No such file or directory
If I go to usr/local/etc/ theres not much there. I do however find the cpanel files under /usr/local/etc/cpanel/ going to base, and then webmail there is NO data file, nor data folder.

I have ran cpanel update in force mode several times
 

PDW

Well-Known Member
Dec 29, 2003
138
3
168
It appears all of the accounts, and yes Ive re-set the password for the ones I have been testing
 

IndoUSHosting

Registered
Nov 26, 2006
2
0
151
We too are facing the same problem.

Permissions are fine, now digging further to see whats going on! Will update the ticket once the problem is solved.
 

braweb

Member
Dec 20, 2004
20
0
151
Colombia
Same Problem

Hello,

We have same problem here, we installed this server this weekend. When we are trying to send an email it just handle the browser and never response.

Thank you!
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Try checking WHM -> Security -> Security Center -> cPHulk Brute Force Protection and see if your server's IP is listed under Brutes. If yes, remove it and you may consider adding your server's IP to the trusted IPs list to prevent this from happening again (if this is the cause of the issue).
 

hbidad

Well-Known Member
Apr 16, 2005
74
1
158
The problem is when you have "Allow mail account authentication using the password of the domain owner's account" enabled, webmail logs you in, but attempts to use the cPanel account password via SMTP. Hence your problem
 

Q-ball

Registered
Jul 28, 2009
2
0
51
Thanks, this fixed my problem.

The problem is when you have "Allow mail account authentication using the password of the domain owner's account" enabled, webmail logs you in, but attempts to use the cPanel account password via SMTP. Hence your problem
 

shengzhongbell

Registered
Aug 18, 2009
3
0
51
The problem is when you have "Allow mail account authentication using the password of the domain owner's account" enabled, webmail logs you in, but attempts to use the cPanel account password via SMTP. Hence your problem
I also have the same problem, I wonder where to disable or enable this option?
In the cpanel or WHM? I can not find it anywhere....
 

shengzhongbell

Registered
Aug 18, 2009
3
0
51
This setting is in WHM -> Server Configuration -> Tweak Settings.
Hi, Thanks for the reply, I have done as you said. But I still have the problem when I using horde. I have created two email accounts ([email protected] & [email protected]) in one of my dedicated server accout: account1. (Note I didn't create email accout:[email protected]) And every time I login to the webmail, when I click new mail or reply mail from my email accout info or admin, the Identity (default identity) is always using the server accout (account1) rather than the email address, which I didn't create such email address in the cpanel, and I can't change the sender here to [email protected] or [email protected])


And I always get error:


There was an error sending your message: Failed to add recipient: [email protected] [SMTP: Invalid response code received from server (code: 550, response: Verification failed for <[email protected]> No such person at this address Sender verify failed)]

Any help please!