The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webmail session failed when changes IP (IP address has changed!)

Discussion in 'E-mail Discussions' started by xsi, Oct 7, 2011.

  1. xsi

    xsi Member

    Joined:
    Oct 7, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi, we have a CentOS server with WHM/cPanel and Horde webmail.

    A customer of ours has 2 lines DSL with a load balancer and uses either at any time transparently. Problem is when they login in Horde, the icons don't show and in a few clicks webmail logout automatically with error "IP address has changed!". We suppose that session is started with an IP, then requests are made fron either and when cPanel/Horde detects the other IP the session fails.

    With the older server Win 2003, the Mailenable server webmail never causes problems to this customer.

    We need that the webmail maintains the session between differents IP addresses.

    We are using http (not https). In /usr/local/cpanel/base/horde/config/conf.php we changed:

    $conf['auth']['checkip'] = true;

    to

    $conf['auth']['checkip'] = false;

    but doesn't work.

    Following instructions at http://forums.cpanel.net/f5/issues-...-cookie-authentication-143121.html#post780381, we have changed in WHM the "Cookie IP validation" option to "loose", but doesn't work.

    In the other hand, when we access to http://webmail.domain.com shows the cPanel webmail login screen. But in Plesk, the login screen is directly from Horde. So, it's possible that error is from cPanel and not from Horde? Is there any way to login directly in Horde bypassing cPanel?

    Thank you!
     
    #1 xsi, Oct 7, 2011
    Last edited: Oct 7, 2011
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You will likely have to disable WHM > Tweak Settings > Cookie IP validation entirely to see if that works. Otherwise, you might have that user utilize a proxy with an unchanging IP to access webmail instead (such as login to a proxy in a browser and then using that proxy to access webmail). The proxy would have to allow secure access to webmail (https) in order to not pose a possible security risk.
     
  3. xsi

    xsi Member

    Joined:
    Oct 7, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yes, we disabled WHM > Tweak Settings > Cookie IP validation entirely but didn't work.
    Do you know proxies services that can be used?

    Thank you!
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    One proxy service would be kproxy.com for https capability. Otherwise, you could install a proxy on your server for them to use. There are online guides for proxy installation via google searches.
     
  5. xsi

    xsi Member

    Joined:
    Oct 7, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page