jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
According to the documentation I should be able to access webmail at

However when I do that and enter the email and password the page refreshes with the following (I've lessened the opacity of the bg image so you can see what's behind it).
- Removed -
 
Last edited by a moderator:

24x7server

Well-Known Member
Apr 17, 2013
1,911
97
78
India
cPanel Access Level
Root Administrator
Twitter
Hi,

From the screenshot, it appears to be related to session ID, but please go through the logs once and paste it here. The cpanel log can be found in /usr/local/cpanel/logs/error_logs
 

tmcstom

Member
Dec 31, 2014
21
4
53
cPanel Access Level
Root Administrator
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
Hello,

The links in the previous post should help address this issue. Let us know if you have any additional questions.

Thank you.
 

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
This maybe due to CloudFlare proxy based on the domain name in the screenshot.


How do I use cPanel with Cloudflare?

My cPanel won't load or keeps logging me out after enabling Cloudflare

Try accessing via the server's IP instead of the domain and see if you get the same results.
Thanks tmcstom, I setup a CNAME record at Cloudflare so that mail points to vps.mydomain.com (grey cloud).
I can now use mail.mydomain.com:2096 and login to webmail.

It would be nice if I could add the port to the value of the CNAME record (so I could use simply mail.mydomain.com), but Cloudflare doesn't seem to allow that (or I just don't know the format).
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
It would be nice if I could add the port to the value of the CNAME record (so I could use simply mail.mydomain.com), but Cloudflare doesn't seem to allow that (or I just don't know the format).
Hello,

The "mail.domain.tld" subdomain isn't supported as a proxy subdomain. However, you could setup the CNAME entry for "webmail.domain.tld" for that purpose.

Thank you.
 

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
When I try to use webmail.mydomain.com I get a 500

500 Internal Server Error
The request was not completed. The server met an unexpected condition.

webmail.xxxxxxx.com/ (port 80)
Please forward this error screen to webmail.xxxxxxx.com's WebMaster.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
When I try to use webmail.mydomain.com I get a 500

500 Internal Server Error
The request was not completed. The server met an unexpected condition.
Could you let us know what's output to /usr/local/apache/logs/error_log when this happens?

Thank you.
 

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
[Tue Aug 22 12:10:41.586999 2017] [:error] [pid 22855] [client 174.89.32.192:59690] SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/index.html" is smaller than min_uid
[Tue Aug 22 12:10:41.587086 2017] [core:error] [pid 22855] [client 174.89.32.192:59690] End of script output before headers: index.html
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
Hello,

If you'd like to use "webmail" as a proxy subdomain, ensure the "Proxy Subdomains" feature is enabled under the "Domains" tab in "WHM >> Tweak Settings". If it is, then ensure the "webmail" DNS entry is an "A" record pointing to the same IP address the other proxy subdomains are setup with.

Thank you.
 

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
Thanks, that works, but it's still necessary to put the port number in the URL.
webmail.mydomain.com:2096 or else I get a certificate warning.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
webmail.mydomain.com:2096 or else I get a certificate warning.
Is the AutoSSL feature enabled for this domain name? It's configured from "WHM >> Manage AutoSSL".

Thank you.
 

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
All accounts are set to

Reset to Feature List Setting
Use setting established by the feature list “default” which is currently set to “enabled”.

Could it be a conflict with Cloudflare's free Flexible SSL certificate?