Webmail slow after login - php settings perhaps?

scristopher

Member
Dec 21, 2012
11
0
1
cPanel Access Level
DataCenter Provider
Hello,
I just started having an issue this morning with slow webmail after logging in. The login is very quick and the user is taken to the "select webmail client" screen very quickly but after selecting either horde or roundcube it is very slow to load up the webmail interface in general, not including the mail showing in the interface.

I am wondering if there are some resource limitations on the webmail/cpanel processes which can be increased because it does not appear I am running low on resources. I'll also add that there are no websites (besides webmail) running on this server, it is only used for email.

There doesn't appear to be a 'huge' number of users logged in:
Code:
[[email protected] ~]# doveadm who| wc -l
username               # proto (pids)                                (ips)     
21
I believe doveadm who should also show webmail logins but this is an assumption based on the fact that webmail uses imap connections.

The load looks fine:
Code:
[[email protected]]# w
 10:57:13 up 41 days, 22:25,  5 users,  load average: 0.97, 0.91, 0.93
Memory usage seems acceptable:

Code:
[[email protected] ~]# free -mh
              total        used        free      shared  buff/cache   available
Mem:            31G        2.7G        267M        1.5G         28G         26G
Swap:           15G         86M         15G
The hardware should be adequate this is the specs:
2x Intel Xeon CPU E5-2630 v4 @ 2.20GHz
Crucial 32GB Kit (4 x 8GB) DDR4-2400 RDIMM 2400 MHz
6x Intel SSD DC S3520 Series (1.6TB, 2.5in SATA 6Gb/s) in a raid 10
Raid 10 is configured using a LSI 9300 MegaRAID SAS 9361-8i (LSI00417)



Are there any memory settings that I could perhaps increase or any other possible limitations?
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,903
2,226
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @scristopher,

It looks like you were able to address this issue per your response in your corresponding support ticket:

What I've done since the ticket was moved was updated the max children in /var/cpanel/php-fpm.d/username.conf and cpanelroundcube.conf
username.conf set to 100 cpanelroundcube set to 500
Here's part of a reply to that from one of our Technical Analysts:

It looks like the max_children was the issue here. The cPanel PHP-FPM parent process was not able to spawn a child process when the limit was being reached, which was causing the delay when accessing Webmail (it had to wait until one of the existing child processes exited). The changes you made were definitely correct and likely what we would have recommended (good catch on adjusting the configuration for the xxxxx user, since that user does appear to have quite a lot of child PHP-FPM processes).
Let me know if you require any further assistance.

Thanks!