Webmail - squirrel, horde and roundcube doesn't work

khorinis

Well-Known Member
Aug 15, 2010
65
0
56
Hello,
I've got another problem today: When I'm logged into Cpanel I try to watch my mails and click on Webmail -> Access Webmail. Then it ask me for the password of the mailbox and I enter it and get the following:
You are logged in as [email protected]

That's fine but when I choose Horde, Squirrel and Roundcube it tell me (all three) that the login failed because of wrong user or password. I tried already the following:
/scripts/buildeximconf
/scripts/reseteximtodefaults
/scripts/makecpphp
/scripts/fullhordereset
I transfered the accounts from an old server, all is working fine, except mails now. Cpanel is running version 11.28.87.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Please run the following command in root SSH:

Code:
/scripts/whoowns domain.com
Where domain.com is the domain name in question. If it doesn't show any ownership, then move the following files:

Code:
cd /etc
mv userdomains userdomains.bak
mv domainusers domainusers.bak
mv trueuserdomains trueuserdomains.bak
At that point, run the following script and recheck ownership for the domain:

Code:
/scripts/updateuserdomains
/scripts/whoowns domain.com
If instead of showing no ownership, the domain showed the wrong ownership, you'd have to edit the /var/cpanel/users/username file that is improperly owning the domain to remove the DNS line that it has for that domain, then run the above move and updateuserdomains commands.

If the ownership is correct, then at that point, try instead checking the Roundcube logs as it has the most accurate logging of the 3 webmail programs. Try to log into the account in Roundcube, and then go to /var/cpanel/roundcube and tail the log:

Code:
tail -fn0 /var/cpanel/roundcube/log/errors
Please post the output of the errors it is logging here at that point.
 

khorinis

Well-Known Member
Aug 15, 2010
65
0
56
When I did the following
/scripts/updateuserdomains
I'm getting this:
warn [updateuserdomains] Unable to read /etc/trueuserdomains: No such file or directory
warn [updateuserdomains] Unable to read /etc/userdomains: No such file or directory
== WORKAROUND ENABLED ==
Serious Problem -- This should never happen!!
The hostname (domain.tld) is owned by the user user2111
== WORKAROUND ENABLED ==
Before it showed no ownership for domain of user2111, that's why I changed the hostname to system.domain.tld and rerun the script
updateuserdomains
. Still no ownership for the domain domain.tld of user2111. Roundcube log doesn't show any error.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
The error message tells you what is wrong:

The hostname (domain.tld) is owned by the user user2111
You've set your hostname for the machine to the same domain as this cPanel account. Since the hostname is owned by nobody, it cannot also be owned by user2111. Please go to WHM > Change Hostname area and change your hostname to server.domain.tld instead of domain.tld. After you've changed the hostname to be a subdomain off the main domain rather than the main domain itself, then re-do the steps I noted to move those files again and run /scripts/updateuserdomains at that point. The ownership should be properly set after you get the hostname off your main domain name.
 

khorinis

Well-Known Member
Aug 15, 2010
65
0
56
I've did that and the ownership of domain.tld is still nothing. Hostname looks like system.domain.tld.

//Edit: I forgot to move the 3 files before retry it. Thanks, it works great! :)
 
Last edited: