The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

webmail subdomain not working when using createacct

Discussion in 'cPanel Developers' started by mcongosto, Oct 15, 2011.

  1. mcongosto

    mcongosto Member

    Joined:
    Aug 1, 2011
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello

    I am using createacct to create new accounts via API.

    Everything seemed fine but I just realized that those domains created with createacct are not resolving automatically generated proxy subdomains like webmail.domain.com. DNS entries are created fine.

    however domain.com/webmail works fine

    Any idea how to fix this? where does cPanel stores this webmails aliases? i though webmail was a regular apache website with aliases, but not.

    whm.domain.com and cpanel.domain.com don't work either. These work fine with domains created manually.

    ftp.domain.com works fine either way, weird..

    any idea?? thanks!!
     
    #1 mcongosto, Oct 15, 2011
    Last edited: Oct 15, 2011
  2. mcongosto

    mcongosto Member

    Joined:
    Aug 1, 2011
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    mental note: don't waste time elaborating questions too much, if people is going to help you they will no matter how much or little time you spend on the OP
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are the newly created accounts on the shared IP or on a dedicated IP? The DNS entries aren't the only location that the proxy subdomains are located. In /usr/local/apache/conf/httpd.conf file, there is a section for PROXY SUBDOMAINS and whenever a new IP is used, it needs to be added to that section. This should happen automatically for account creation.

    Here's a question. If you run "/scripts/rebuildhttpdconf" and then restart Apache, do the proxy subdomains work then?

    Also, I prefer specifics, so I appreciate the details provided thus far. The less details included in a post, the more questions I end up having to ask before I can even help the person.
     
  4. mcongosto

    mcongosto Member

    Joined:
    Aug 1, 2011
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    they are on shared ip. Now I think it has to do with htaccess beacuse it works for some domains. I will checkot https.conf and let yyou know.

    thank you!
     
  5. bEgUnDaL

    bEgUnDaL Member

    Joined:
    Nov 28, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    This thread solves my problem.
    was getting the wrong page when tried to open either webmail or cpanel subdomain.
    after executing /scripts/rebuildhttpdconf and restarted apache cpanel and webmail subdomain works again.
    Thank you @cPanelTristan
     
Loading...

Share This Page