Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Website loading takes more than 6 minutes with mod_http2

Discussion in 'EasyApache' started by Jafar Muhammed, Aug 2, 2017.

Tags:
  1. Jafar Muhammed

    Jafar Muhammed Active Member

    Joined:
    Mar 21, 2017
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    I have enabled mod_http2. I was using mod_mpm_prefork, and after reading Prefork and HTTP2, I switched to mod_mpm_event. Everything is super cool.

    Now, my website is taking more than 6 minutes to finish loading. Actually, my website contents are finished loading in a few seconds, like less than 20 seconds. However, I have tawk.to installed on my website, and it seems the extension is having an issue with Switching protocols. And (I guess) due to this behaviour, I can see the loading spinner of the browser in action nearly five to six minutes. After this, the browser seems to give up and finish(? ) the loading.

    Another thing I noticed that there would be any random files from my server getting stalled in the request queue and eventually getting failed when the browser stops loading.

    I tried to switch mod_mpm_worker with mod_http2 to see if it is an issue with mod_mpm_event and found that, it is probably with mod_http2. Right now, I have disabled mod_http2 and running with mod_mpm_event. As expected, my websites are being served within reasonable seconds.

    I don't know if I need to change any configuration to resolve this. I am looking for your input.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Do you notice any entries in /usr/local/apache/logs/error_log when this happens? Have you checked with the support team for this application to verify there are no compatibility issues with HTTP2?

    Thank you.
     
  3. Jafar Muhammed

    Jafar Muhammed Active Member

    Joined:
    Mar 21, 2017
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi @cPanelMichael, I have this line.
    Code:
    [Thu Aug 03 00:40:23.767568 2017] [access_compat:error] [pid 22779:tid 140028409775872] [client 158.69.63.119:41368] AH01797: client denied by server configuration: /home/threadly/public_html/app/etc/config.php
    I saw this from cPanel > Metrics > Errors. Similar errors are logged daily, multiple times.

    I have checked the file /home/threadly/public_html/app/etc/config.php and found below details. It is a list of Magento's plugins and extensions.
    PHP:
    <?php
    return array (
      
    'modules' =>
      array (
        
    'module_name' => 1,
      ),
    );

    I have contacted Tawk.to's Support team on July 29th, no response from them yet.
    I have disabled Tawk.to module from Magento's admin panel, and I can see the same issues. Even if I disabled Tawk.to, the site takes 5+mins to load.

    I am checking the loading from Google Chrome's incognito mode. I have disabled the
    mod_http2, and now the site is finishing loading faster.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    What permissions are configured for this file, and it's parent directories? Did you use previously use Mod_Ruid2 when the Prefork MPM was enabled?

    Thank you.
     
  5. Jafar Muhammed

    Jafar Muhammed Active Member

    Joined:
    Mar 21, 2017
    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello @cPanelMichael,

    Here are the permissions details.

    /public_html/app/etc/config.php set to 644
    /public_html/app/etc and /public_html/app set to 755

    The mod_ruid2 was disabled when I was using mod_mpm_prefork. It is disabled now also.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Feel free to open a support ticket using the link in my signature if you'd like us to take a closer look.

    Thank you.
     
Loading...

Share This Page