Website Suddenly Returns Empty Response and Other WP Robot Fails

Operating System & Version
CENTOS 7.9
cPanel & WHM Version
94.0.4

PostAlmostAnything

Active Member
Mar 3, 2020
34
0
6
Portland, Oregon
cPanel Access Level
Website Owner
What changes have been made since 4/12 that might explain why one of my websites loads only " ERR_EMPTY_RESPONSE " in Chrome and others display error messages that say " Error: Post could not be created because main module failed. " whenever I try to run a WP Robot campaign in Wordpress. I have literally done nothing to these sites at all for a long time and just now discovered this problem. At first I thought that my version of Wordpress may have updated automatically, but that does not appear to be the case.

I checked cPanel for errors and there are none from this time period.

The ERR_EMPTY_RESPONSE appears to have been happening for just a day or so because I have received emails via contact page on that site from a couple days back.
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Hey there! Your user profile here on the forums indicates you only have cPanel-level access to the machine, so you wouldn't be able to check any higher-level error logs to see more details. While you may not have made a change, server-side software does constantly update, so it's possible there was a change made by the host that could affect this.

I'd recommend reaching out to the hosting provider or datacenter to see if they can check things on their end and get you more details.
 

PostAlmostAnything

Active Member
Mar 3, 2020
34
0
6
Portland, Oregon
cPanel Access Level
Website Owner
Hey there! Your user profile here on the forums indicates you only have cPanel-level access to the machine, so you wouldn't be able to check any higher-level error logs to see more details. While you may not have made a change, server-side software does constantly update, so it's possible there was a change made by the host that could affect this.

I'd recommend reaching out to the hosting provider or datacenter to see if they can check things on their end and get you more details.
I have root access, but I'm not used to it because I normally work in a Windows environment. I had to repair a database and then the site that was returning nothing loaded, but started doing the same thing an hour later. I tried repairing the DB again, but that did not help. I checked the error logs in cPanel and the PHP errors on the file system. There are none, so basically I have an error with an unknown cause and no leads to go on.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Do you see the same error in other browsers, such as Firefox? One test you can do from your local workstation would be to try and access the site with "curl" on the command line, to see if that gives you any additional details on the error. You can do that with this command:

Code:
curl -v http://yourdomain.com
Can you try that and see if that gives you more information?
 

PostAlmostAnything

Active Member
Mar 3, 2020
34
0
6
Portland, Oregon
cPanel Access Level
Website Owner
Do you see the same error in other browsers, such as Firefox? One test you can do from your local workstation would be to try and access the site with "curl" on the command line, to see if that gives you any additional details on the error. You can do that with this command:

Code:
curl -v http://yourdomain.com
Can you try that and see if that gives you more information?
The loading error went away for unknown reason, but the WPROBOT campaigns still do not run despite the cron job running properly.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
I'm glad the page is loading now.

For the campaign issues, you'd likely need to do some additional troubleshooting specifically with wprobot. If you don't see anything helpful in their documentation here:


You may need to contact their support team directly for more details: