Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Websites stop working after installation of tomcat 7 thru easyapache

Discussion in 'EasyApache' started by q8developer, Jun 26, 2014.

  1. q8developer

    q8developer Member

    Joined:
    Jul 11, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi i try to install tomcatcat 7 thru easy apache which is done successfully but all my websites under one reseller stop working plz need some help any idea wut happend?

    [Removed]
    Not working
     
    #1 q8developer, Jun 26, 2014
    Last edited by a moderator: Jun 27, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,664
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you elaborate further on how your websites are not working? What is output to the Apache error log (/usr/local/apache/logs/error_log) when the websites fail to load?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. q8developer

    q8developer Member

    Joined:
    Jul 11, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    send: Connection refused at /usr/local/cpanel/Cpanel/Linux/Netlink.pm line 174
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,664
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    To confirm, you see that message in the Apache error log and not the cPanel error log? Do you have any firewall rules or third-party applications installed that could result in that message? Are you using Apache or another web server such as LiteSpeed?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. q8developer

    q8developer Member

    Joined:
    Jul 11, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    yaa i have plugin called LogView - 3.5 in WHM to see all log and this is wut i find diff. in the error_log.

    and yes im using asa5500 firewall as well
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,664
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    You may want to review your firewall configuration and verify it's not causing this issue.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. q8developer

    q8developer Member

    Joined:
    Jul 11, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanx alot it was firewall issue now websites are working fine

    - - - Updated - - -

    btw regarding tomcat 7 i install in thru easy apache and now i can see icons for restart servlet server and install servlets

    i install servlet on one of my websites but still jsp is not working on it www.ihcq8.com/jsptest.jsp
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,664
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I am happy to see the initial issue was resolved are modifying your firewall rules. As far as the second issue, you can open a support ticket and we can verify that a JSP test page works as intended. Post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. q8developer

    q8developer Member

    Joined:
    Jul 11, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Your Request id is: 5183219.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,664
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    To update, this issue was addressed by updating group ownership of the tomcat user to "nobody".

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. cPanelKurtN

    cPanelKurtN Well-Known Member
    Staff Member

    Joined:
    Jan 29, 2013
    Messages:
    95
    Likes Received:
    1
    Trophy Points:
    83
    cPanel Access Level:
    Root Administrator
    Case 108257 has been opened to resolve this issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice