The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weird cPanel Errors

Discussion in 'General Discussion' started by ee99ee, Dec 10, 2003.

  1. ee99ee

    ee99ee Well-Known Member

    Joined:
    Aug 15, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    MySQL Problems -- MySQL dead

    I'm running cPanel 8.5.4-R7 on RedHat 9.0. Kernel is 2.4.20-20.9.

    When I login to cPanel, under General Account Information, next to MySQL, it says "/var/cpanel/users/cpanel / 9999". This should say the number of databases I would think. But then that takes us on to the next MySQL problem.

    When I try to create a new MySQL database, I get the following:

    "Database Created
    Added the database test. /var/cpanel/users/cpanel"

    Then I go back to the database manager, and there are no databases listed. I logged into the server and looked at MySQL with the CLR client, and it indeed didn't create the database. Same thing with trying to add users to MySQL.

    EDIT: I edited this post. This is now the only problem. The other problem that I used to have fixed it's self.

    -ee99ee
     
    #1 ee99ee, Dec 10, 2003
    Last edited: Dec 11, 2003
  2. parasane

    parasane Well-Known Member

    Joined:
    Oct 19, 2003
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dickson City, Pennsylvania (USA)
    It seems like anytime I check support boards, the ONLY posts that have absolutely zero replies are the ones that describe the exact problem I'm having at the time. I suppose this is fine, because like all of the other times (such as with xCart, vBulletin, and now cPanel, among many others) I've been finding the solutions myself. In my opinion, it may take a little bit longer, but it makes you a better programmer.

    Anyway, here's what I'm guessing would fix the above problem, because it did it for me. This is all done from the command line as root on a client's site (I don't use cPanel on my own servers, I'm a term junky! ;-P):

    1.) Go to /var/cpanel/users
    2.) Type "ls cpanel" (without the quotes, and substituting the username in question for "cpanel." Mine was "admin."
    3.) Does the file exist? If so, make sure it looks like the one in figure 1.0, then skip to step 5. If not, copy this information, but place your own relevant info into it, in place of what I've entered here.

    Figure 1.0
    Code:
    BWLIMIT=1000000000000
    DNS=mydomain.com
    DNS1=mydomain.com
    IP=123.45.67.89
    LANG=english
    MAXFTP=999999
    MAXLST=999999
    MAXPOP=999999
    MAXSQL=999999
    MAXSUB=999999
    OWNER=root
    PLAN=Plan I
    RS=x
    STARTDATE=1013967040
    
    In the figure above, here are the explanations:

    • BWLIMIT - The BandWidth Limit (Here set to one terrabyte.... if he exceeds that, he NEEDS to be shut off!)
    • DNS - The client's domain
    • DNS1 - Another domain (I used the same domain both times)
    • The IP Address
    • Language (Duh!)
    • Maximum Allowed Unique FTP Clients (Here is one less than a million.... that should do it)
    • Maximum Mail Lists
    • Maximum POP3 Accounts
    • Maximum MySQL Databases
    • Maximum Subdomains Allowed
    • Who Brought This Account In?
    • What Plan Are They Using (I don't even have plans set up, but this works)
    • RS=x means that I want to use the x Skin for my cPanel
    • StartDate is in Unix Epoch Format.... Google for more information on that, as it's beyond the scope of this walkthrough)
      [/list=a]

      4.) Save the file as the username of the account you're trying to fix.

      5.) Check the ownership. If cPanel is running in the default setup, then the user is cpanel. Change this file like so (again, without the quotes): chown cpanel:cpanel cpanel"
      (Or in my case, "chown cpanel:cpanel admin")

      6.) Set the permissions. I'm just going to set it as world-writeable, readable, and executable. I know it's a hazard to do so, but this is non-production at this point. Let's set this to -rwxrwxrwx.
      "chmod 777 cpanel" (Or "chmod 777 admin")

      7.) Log in as cpanel (or whatever user you just did this file for) and see if things work now. If you're problem was like mine, this will have fixed it.

      I don't even know if I've done anything else here like it should have been. I would have thought cPanel would do this for you, but maybe I thought wrong. All I know is that it works, and if someone knows a different way, they're more than welcome to add it or correct me.

      And just for the information, here's my speclist:
      • PIV 2.4GHz
      • 512MB
      • RH9
      • cPanel 8.5.5-R60
      • WHM 8.5.4
      • X 2.1.1
      • Sober (I need a beer now)
     
Loading...

Share This Page