Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Weird Database problem

Discussion in 'Database Discussion' started by Desarbres, May 7, 2014.

  1. Desarbres

    Desarbres Registered

    Joined:
    May 4, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I have a VPS running Centos 6.5 with WHM/Cpanel and the latest versions of PHP/Apache?MySQL. I have a couple of sites on the box running ecommerce software - Cubecart 5.

    Up until yesterday the sites were running fine. I have anew client who also wants a Cubecart shop so I downloaded the latest version and uploaded it to the site, extracted the files, created the database and ran the installer. All went well until I tried access the ADMIN section, I saw this message:


    Notice: `name` is not allowed as a key in 'CubeCart_config' table! in /home/hkudhirt/public_html/classes/db/database.class.php on line 794

    I then tried the SHOP section and saw exactly the same thing. At that moment the phone rand and the owner of the other Cubecart - which has been running fine for the last 2 months - told me that hist shop had stopped working.

    After a lot of head scratching and Googling, I think the problem has to do with permissions but I can't find out where I need to make changes. I did notice when I looked at all the databases on the server with WHM PHPMYADMIN that a couple of the usernames were grey and in italics and there is a little symbol beside them - picture attached.
    db-symbol.gif

    Has anyone any ideas of what I can do to sort this out?

    Thanks for reading

    Tim
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,423
    Likes Received:
    1,956
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice