The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weird Exim issue .. stuck queue but can deliver manually?

Discussion in 'General Discussion' started by rpmws, Aug 24, 2004.

  1. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Weird Exim issue .. stuck queue but can deliver manually? Here is what the headers look like if I view the message in the WHM mail queue. Note that these are a list of about 500 emails. They ramp up my queue to about 600 and it stays there until they are automatically deleted or deleted by me. I can hit "deliver message now" and it goes out no problem in like 1/2 second. Almost all of them listed in there that are in queue will deliver, they just won't go out automatically. Header below...thanks in advance.

    1BzNK4-00044G-T7-H
    root 0 0
    <mail@hisdomain.com>
    1093300192 0
    -helo_name hisdomain.com
    -host_address 200.78.83.122.62151
    -host_name dsl-200-78-83-122.prod-infinitum.com.mx
    -host_auth fixed_login
    -interface_address my.server.ip.is.here.25
    -received_protocol asmtp
    -body_linecount 202
    -auth_id mail@histdomain.com
    -deliver_firsttime
    XX
    1
    arealuser@yahoo.com

    214P Received: from dsl-200-78-83-122.prod-infinitum.com.mx ([200.78.83.122] helo=hisdomain.com)
    by my.fullservername.com with asmtp (Exim 4.41)
    id 1BzNK4-00044G-T7
    for arealuser@yahoo.com; Mon, 23 Aug 2004 17:29:54 -0500
    042 Mail-System-Version: Broadc@st HTML 4.5.1
    024 X-Sender: mail@hisdomain.com
    038 Date: Mon, 23 Aug 2004 17:23:14 -0500
    098F From: "Deanna and Chris Clark - Life Giving Outreach Ministries, Reynosa, Mexico" <mail@hisdomain.com>
    053T To: "Alice and Nicholas Bentin" <arealuser@yahoo.com>
    067 Subject: God at work through the hearts and hands of his faithful.
    024R Reply-To: mail@hisdomain.com
    018 MIME-Version: 1.0
    024 Content-Type: text/html

    Can somone tell why these just won't go out? ..oh ..i checked the loads and they are low.
     
    #1 rpmws, Aug 24, 2004
    Last edited: Aug 24, 2004
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That is odd. If you run the following, exactly do you get?

    ps axf | grep -v grep | grep exim
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    been running edge builds for 2 years, this has been an issue since day one, about a year ago for this user. All other mail delivers fine. Also upgraded to latest exim and same deal :(

    23173 ? S 0:01 /usr/bin/perl /usr/local/cpanel/bin/eximstats
    25664 ? S 0:01 /usr/sbin/exim -bd -q20m
    1865 ? S 0:00 \_ /usr/sbin/exim -q
    31239 ? S 0:00 | \_ /usr/sbin/exim -q
    31242 ? S 0:00 | \_ /usr/sbin/exim -q
    9300 ? S 0:00 \_ /usr/sbin/exim -q
    32330 ? S 0:00 | \_ /usr/sbin/exim -q
    32331 ? S 0:00 | \_ /usr/sbin/exim -q
    15730 ? S 0:00 \_ /usr/sbin/exim -q
    349 ? S 0:00 | \_ /usr/sbin/exim -q
    350 ? S 0:00 | \_ /usr/sbin/exim -q
    31232 ? S 0:00 \_ /usr/sbin/exim -bd -q20m
    32339 ? S 0:00 \_ /usr/sbin/exim -bd -q20m
    395 ? Z 0:00 | \_ [exim <defunct>]
    32559 ? S 0:00 \_ /usr/sbin/exim -bd -q20m
    416 ? S 0:00 \_ /usr/sbin/exim -bd -q20m
    432 ? S 0:00 \_ /usr/sbin/exim -bd -q20m
    433 ? S 0:00 \_ /usr/sbin/exim -bd -q20m
    473 ? S 0:00 \_ /usr/sbin/exim -bd -q20m
    474 ? Z 0:00 \_ [exim <defunct>]
    25671 ? S 0:00 /usr/sbin/exim -bd -oX 26
    25677 ? S 0:00 /usr/sbin/exim -tls-on-connect -bd -oX 465
    31386 ? S 0:00 /usr/sbin/exim -Mc 1BzcNH-00088f-Ag
    31394 ? S 0:00 \_ /usr/sbin/exim -Mc 1BzcNH-00088f-Ag
    32595 ? S 0:00 /usr/sbin/exim -Mc 1BzcQi-0008Pd-13
    32601 ? S 0:00 \_ /usr/sbin/exim -Mc 1BzcQi-0008Pd-13
    32609 ? S 0:00 /usr/sbin/exim -Mc 1BzcQm-0008Tq-Ta
    32616 ? S 0:00 \_ /usr/sbin/exim -Mc 1BzcQm-0008Tq-Ta
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, that looks OK to me. That seems to show that you're running your queue process every 20 minutes (the -q20m ones) and it's trying to dequeue emails (the -q ones).

    The best thing I can suggest would be to (on a Linux server) setup a monitor window with:

    tail -f /var/log/exim_mainlog

    In another window, stop and restart exim:

    /etc/init.d/exim restart

    Exim should run a queue on startup and you ought to see any errors in the other window as to why it is not delivering.

    A couple more things:

    1. What do you have at the very end of your /etc/exim.conf?

    It ought to look something like:
    Code:
    *                      *           F,2h,15m; G,16h,1h,1.5; F,4d,8h
    2. Have you had MailScanner installed in the past and removed it? If so, what do the first 10 lines or so at the top of your /etc/exim.conf look like?
     
  5. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    I run tail on my exim_mainlog all teh time on a machine I use for MRTGs and logs. When I restart exim it's like it skips over these emails ...but YES I did have mailscanner installed and infact when I restart exim I see errors. I removed mailscanner on this bax some time ago becuase of the loads it was causing... what should I look for a change to make sure I don't have any old mailscanner inteferace ?

    I am showing this at end of exim.conf

    Code:
    *                      *           F,2h,15m; G,16h,1h,1.5; F,4d,8h
     
    #5 rpmws, Aug 24, 2004
    Last edited: Aug 24, 2004
  6. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA

    also when I restart exim I get this.

    Shutting down clamd: [FAILED]
    Shutting down exim: [ OK ]
    Shutting down antirelayd: [ OK ]
    Shutting down spamd: [ OK ]
    Starting clamd: ERROR: Can't open config file /etc/clamav.conf !
    ERROR: Can't parse the config file /etc/clamav.conf
    [FAILED]
    Starting exim: [ OK ]
    Starting exim-26: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]
    Starting spamd: [ OK ]


    Don't have mailscanner running.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you're not using clamav you can clear up those errors with:
    Code:
    rm -Rfv /usr/bin/clam*
    rm -Rfv /usr/sbin/clam*
    rm -Rfv /usr/lib/libclam*
    rm -Rfv /usr/share/clam*
    rm -Rfv /usr/include/clam*
    rm -Rfv /usr/bin/freshclam*
    rm -Rfv /usr/etc/clamav*
    I suspect you've got some MailScanner stuff hanging around. I would suggest doing this first:

    /scripts/buildeximconf

    Then, check the top of exim.conf and make sure that you do not have any of the following lines at the top:
    Code:
    spool_directory = /var/spool/exim_incoming
    queue_only = true
    queue_only_override = false
    Then restart exim:

    /etc/init.d/exim restart
     
  8. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Thanks so much for all your help chirpy. That got rid of all the clam stuff and I **think** I just saw a hand full of those queued email leave!!!!
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's great ;) It may take a while for them to all become unforzen, but if you go into WHM > Manage Mail Queue > and click Attempt to Deliver all messages in Queue you gave give it a hurry up.
     
  10. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    I know this is an old thread, but Chirpy, we've got MailScanner running on all of our servers, and also have very heavy problems with excessive queues, i.e. usually in the range of 6k to 22k messages in queue. Some have been there as long as 110 days.

    I have added this at the top of the exim.conf file:

    auto_thaw = 6d
    ignore_bounce_errors_after = 7d
    timeout_frozen_after = 8d


    But I also have this at the top of the file as well:

    spool_directory = /var/spool/exim_incoming
    queue_only = true

    Should I comment out both of these lines (above)? Would that mess up MailScanner if I did?

    Thanks much.

    P.S. Also, is there any automatic way of purging these thousands of messages that are older than 8 days?
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You should never edit exim.conf directly, simply use the Exim Configuration Editor. If you remove those lines from exim.conf you will break MailScanner and email delivery.

    If you're getting a large queue, why are you keeping those emails in the queue for such a long time. I'd suggest not using auto_thaw and changing the settings to:

    ignore_bounce_errors_after = 1d
    timeout_frozen_after = 4d

    There's no reason to keep emails in the queue after 4 days as that's as long as is normally expected.
     
  12. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    Okay, did that using the WHM exim config editor, HOWEVER, I see that further down the page, we have the following which is in an un-editable area:

    # primary_hostname =
    deliver_queue_load_max = 3
    auto_thaw = 6d
    ignore_bounce_errors_after = 7d
    timeout_frozen_after = 8d

    I am puzzled as to why these settings had no effect if they were already on the exim.conf file.

    ALSO, I would love to change the deliver_queue_load_max setting to 10 or 14 because this particular server is under a continuual high load, and I think the queing sessions are not running because of this.

    But apparently, the only way to change the deliver_queue_load_max setting is by editing the exim.conf directly? Which you say I could never do?
     
  13. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    I am still puzzeled why the other settings had no effect (i.e. if email was supposed to be deleted after 8d why we were seeing email still in queue after 110d.

    But please know that I found the answer to the other quesitons in this post - deliver_queue_load_max = 6

    Thanks much for your help and for any response to the remaining quesiton.
     
Loading...

Share This Page