The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wget can access external sites, but unable to access local ones

Discussion in 'General Discussion' started by tamalero, Mar 4, 2013.

  1. tamalero

    tamalero Member

    Joined:
    Mar 4, 2013
    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Greetings gentlemen,

    I have a cPanel installation using Peer1(serverbeach)'s brand of Dedicated Hosting.

    After some trouble with the OS which was resolved, I noticed that the Wget conjobs I use were giving errors.

    Example:

    If I do a wget Google
    the process is successful.

    but if I use any of the local websites I'm hosting, it gives an error.


    Uname reports:
    using cPanel latest with Bind.

    any ideas what could be cause?
     
  2. tamalero

    tamalero Member

    Joined:
    Mar 4, 2013
    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Found some interesting aspects.. I can use wget to mysite.com but not to www.mysite.com
     
  3. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Without knowing your configuration I would guess the problem is in the resolver.
    Check /etc/resolv.conf
     
  4. tamalero

    tamalero Member

    Joined:
    Mar 4, 2013
    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    should be looking for something in special?
    I did review it a few ago and it seemed fine (it has the nameserver ips of my provider, aka peer1's)
     
Loading...

Share This Page