The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What are the valid combinations for php 4 and 5 handlers?

Discussion in 'General Discussion' started by gflamerich, Nov 2, 2008.

  1. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    We spent the last 4 hours reading the forum and some cpanel documentation and still don't fully understand the options available for the config. (Configure PHP and SuExec)

    We tried a few but don't know if what we are doing is correct.
    The box we are trying to config has php 4 and 5 with Apache 2.2 with suExec enabled, php5 running as cgi and php4 as dso.
    (We know this runs, but wanted to know if this is the best option)

    We read that we may use FastCGI, when we enabled it, the option that allows the user to change php version is not available (is this the expected behavior?)

    Can anyone post a simple explanation of what are the possible/recommended options for the php4 and 5 handlers?
    (For example: if you set one version to dso, the other can't be dso and should be selected between this and that...)

    Thanks in advance
     
  2. sirotex

    sirotex Well-Known Member

    Joined:
    Jul 10, 2008
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Yes that is a good option.

    I think most scripts are now ported to PHP 5, so i wouldn't really worry about keeping PHP 4, infact we have removed PHP 4 from our systems with no complaints. (So far atleast..)
     
Loading...

Share This Page