The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What's the latest php version that works with phpsuexec?

Discussion in 'General Discussion' started by silversurfer, May 3, 2004.

  1. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    Hi

    I understand that there is a lag between the releases and phpsuexec.

    What's the most current version that would work with phpsuexec.

    Is there a site I can refer to in future? thanks.
     
  2. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    I'm running PHP 4.3.4 with phpsuexec.
     
  3. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    I had tried that but been getting Internal server 500 errors and with the logs spewing lots of errors and changing it to 755 don't help either.

    Mine sharing the configure line (i.e. what modules you used?)

    Also what I did was

    1. Download PHP 4.3.4
    2. Configure
    3. Make
    4. Make install
    5. Recompile Apache to PHPSuexec.

    What did I do wrong ? thanks.
     
  4. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    An example error message

    [Mon May 3 22:50:49 2004] [error] [client xxx.252.xxx.xxx] malformed header from script. Bad header=<!DOCTYPE HTML PUBLIC "-//W3C/: /home/xxxx/public_html/bboard/viewtopic.php

    You also see a smattering of php functions errors. What's wrong :(
     
  5. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    I'm not into hard work, I just used easyapache.

    Here's my config if you like to do it by hand:rolleyes:

    './configure' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-mcrypt' '--with-mhash' '--enable-magic-quotes' '--with-pear' '--enable-safe-mode' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-versioning' '--with-xmlrpc' '--with-zlib'
     
  6. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    I'm using 4.3.6 with phpsuexec no problem.

    I'm going to give 5.0RC2 a try with the phpsuexec patch and suphp later this week. :D
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
Loading...

Share This Page