The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What's the supported postgresql version?

Discussion in 'Database Discussions' started by kjg, Jun 17, 2012.

  1. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Hi all,
    Been reading all posts about postgresql versions in cpanel and understands that it is what's in the CentOS repository that is "supported by cpanel".

    The actual server runs CentOS 5.8 and WHM 11.32.3

    Installed postgresql version is 8.1.23-4.el5_8
    Running yum list postgres* shows both
    8.1.23-4.el5_8
    and
    8.4.11-1.el5_8

    So my simple question is: Is 8.4 "supported" by cpanel so we can upgrade to 8.4 without anticipating too many problems or are we stuck with 8.1 if we want to keep the server at a stage where it is "supported" by cpanel?

    // kjg
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I am showing both in the list for the repos I'm checking, but we appear to selectively pick 8.1.23. We do have an internal case to support PhpPgAdmin for PostgreSQL 8.4 (that's case 40214), so we have done some testing for it. I cannot state everything would work, but per 40214 where it was noted that 8.4 is in the repo, development is indeed aware it exists there.
     
  3. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Thank you for your quick response.
    I am not sure how to interpret your answer but I guess you say "wait for another couple of weeks" before you upgrade to 8.4, and that 8.1.23 is the "supported version" still.

    How can I see the "case 40214" and any progress report on that one?

    // kjg
     
  4. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Hi again,
    I just found case 40214. It was implemented already with WHM 11.29.0.11 released 30-Mar-2011.
    I am sorry, but English is not my native language and I am not sure I understand your comments. I thought that 40214 was someting you worked on and not something that was already released over a year ago.

    // kjg
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hi kjg,

    The case added support for 8.4 postgreSQL for PhpPgAdmin so that it didn't error when someone had 8.4 installed. It didn't add support for us to provide 8.4 with cPanel installations. We still install 8.1 as we are picking that rpm rather than 8.4. If you want to upgrade to 8.4, you can, but we don't provide it. We are aware it exists and has existed in the repositories for CentOS and RHEL via yum for awhile now, but we haven't switched to providing it. As such, we have customers who have added it and we have a case where we added support for PhpPgAdmin to work with it.

    I'm not stating when we will add it or if we will add it for 8.4. I'm just providing facts on what case implemented support for it working with PhpPgAdmin and that we know it exists (we being development here). I cannot state more than that. You'd be using it at your own risk just as you'd use anything we don't install for a set version at your own risk. If things don't work, you can open up a ticket, but we might well not fix the issue it is having. It's up to you there on what you decide to do.

    Thanks!
     
  6. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Thank you for the reply. Now I understand :) and will stick to 8.1.23 for a while longer and hope that you will add support for 8.4 sometime soon

    // kjg
     
  7. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Hi again Tristan
    Just got some positive info when setting up a new server with CentOS 6.2 and WHM 11.32.3.19.

    When installing postgreSQL on that server, the version that gets installed is 8.4! Yippieeee :)

    (Unfortunately when testing on a CentOS 5.8 server, the version installed is still 8.1)

    So you are now supporting 8.4 for CentOS 6.2 installations but 8.1 for CentOS 5.8 installations? As noted earlier in this thread, both 8.1 and 8.4 are in the repos for CentOS 5.8.

    But that is good new for us. We are in the process of upgrading most of the servers still running CentOS 5.x to 6.2 so the PostgreSQL issue will be solved at the same time.
     
  8. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The installer script uses whatever the operating system vendor determines the postgresql and postgresql-server packages should be. We don't support one version of PostgreSQL over the other, at this time.
     
Loading...

Share This Page