The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

When will we get the new GD with GIF support?

Discussion in 'General Discussion' started by AaronB, Jul 24, 2004.

  1. AaronB

    AaronB Registered

    Joined:
    May 14, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    With the release of 2.0.28 of GD which has GIF support added back in, when will it be available as in install on cpanel? Or does it have to come with PHP, meaning that they have to release a new 4.x version?
     
  2. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    cPanel compiles GD using the bundled library. at the moment the bundled one is 2.0.23

    If you wish to use 2.0.28 this is what you need to do:

    cd /home/cpapachebuild/buildapache
    nano buildscript

    whenever you see "--with-gd" replace it with "--with-gd=/usr"

    now exit nano by hitting ctrl + x

    wget http://www.boutell.com/gd/http/gd-2.0.28.tar.gz
    tar zxf gd-2.0.28.tar.gz
    cd gd-2.0.28
    rm -fr config.cache
    ./configure --prefix=/usr
    make clean
    make libgd.a
    make
    cp -fv .libs/libgd.a .
    make install

    cd /home/cpapachebuild/buildapache
    ./buildscript
     
  3. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    I think I will wait, but thank you for the HOWTO :)
     
  4. Nox

    Nox Member

    Joined:
    Jun 28, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    The procedure Sinewy outlines above doesn't seem to work on my Fedora Core 1 box. Every time I try to make gdlib.a it complains with a 'No target to make: gdlib.a' message. :(

    Does anyone else know any means of getting GD 2.0.28 into the CPanel Apache compile?

    The guys at CPanel should REALLY update the bundled version, 2.0.28 is a landmark release since it finally supports GIF output.
     
  5. patchwork

    patchwork Well-Known Member

    Joined:
    Nov 2, 2001
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    16

    I just tried it on CentOS and it didn't work, I also get an error when I run "make libgd.a"

    Pete
     
  6. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Maybe people posting HOWTOs should start including the cPanel/OS/Kernel versions and notes about whether the process has been tested and any special (not including in the default cPanel/OS/Kernel configuration) requirements.
     
  7. infronthost

    infronthost Registered

    Joined:
    May 5, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Sucessful Update of GD 2.0.28 on WHM/CPanel V9.7.7 R15 - Redhat Enterprise

    Steps Involved.

    1) Placed gd-2.0.28.tar.gz in /usr/local and Expanded the archive as per the How-To Above
    2) Replaced all occurences of /usr in the How-To with /usr/local

    I followed the rest of the steps, I did receive an error on "make libgd.a" but continued anyway and it installed perfectly.

    Thanks Sinewy for the How-To

    Regards,
    Michael
     
  8. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    THanks for the info, you rule!
    One question, why do you need to put libgd.a on level higher?
     
  9. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    Its easiest just to run ./configure make and make install, the cpanel apache build script sucks and is too slow

    These 12 commands work perfectly:
    wget http://www.boutell.com/gd/http/gd-2.0.28.tar.gz
    tar -xzvf gd-2.0.28.tar.gz
    cd gd-2.0.28
    ./configure --prefix=/usr/local
    make
    make install
    cd /home/cpphpbuild/php-4.3.8
    './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-ftp' '--with-gd=/usr/local' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-mcrypt' '--with-mhash' '--with-ming=../ming-0.2a' '--enable-magic-quotes' '--with-mysql' '--with-openssl' '--enable-discard-path' '--with-pear' '--with-pspell' '--enable-xslt' '--with-xslt-sablot' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-versioning' '--enable-wddx' '--with-zlib'
    make
    make install
    /etc/rc.d/init.d/httpd restart
    /etc/rc.d/init.d/httpd start
     
  10. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    Your php info file will read:
    gd
    GD Support enabled
    GD Version 2.0 or higher
    FreeType Support enabled
    FreeType Linkage with freetype
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled

    "GIF Create Support enabled" means it GD 2.0.28
     
  11. brentp

    brentp Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ayr, North Queensland, Australia
    Script

    I'll try to code a perl script that does it tonight
     
Loading...

Share This Page