The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Where do I change Apache ServerAdmin email address in httpd.conf?

Discussion in 'E-mail Discussions' started by outofcontrol, May 18, 2009.

  1. outofcontrol

    outofcontrol Member

    Joined:
    May 18, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Montreal
    Hello,

    I am quite familiar with Linux and Apache, and normally configure by hand my files. I now have my first cPanel box and seem to be at a loss on how to change the ServerAdmin email address in httpd.conf. Currently my cPanel box is up and running and properly hosting sites.

    I have looked in the control panel at domain.com:2087 under Apache Configuration and Basic cPanel/WHM Setup, as well as having gone through the other configuration files in the left column. Where an email address is requested, I have entered my valid email. However, when the apache file is rebuild it shows the original email address from when I first got the server which is root@myname.theplanet.host.

    It would appear obvious that I have missed something, but for the life of me, I cannot find what.

    Is there anyone out there that can offer me a suggestion on how to make this change.

    Thank you.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    In WHM, find the "Change System Mail Preferences" section. There you can set your email(s) up for the server's email(s). :)

    HTH
     
  3. outofcontrol

    outofcontrol Member

    Joined:
    May 18, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Montreal
    I just checked /var/cpanel/cpanel.config and see no address there, but saw that I should run /usr/local/cpanel/whostmgr/bin/whostmgr2 --updatetweaksettings after changes. I did that, however, the wrong address still shows in /usr/local/apache/conf/httpd.conf
     
  4. outofcontrol

    outofcontrol Member

    Joined:
    May 18, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Montreal
    Unfortunately I had already set those. I did go back and resave each setting and then rebuild the Apache config file, however, the httpd.conf file still shows the wrong root@myname.theplanet.host address.
     
  5. outofcontrol

    outofcontrol Member

    Joined:
    May 18, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Montreal
    Okay, found it. I had to manually edit /var/cpanel/conf/apache/main to make the change. I then rebuilt the apache files and all is fine now.

    I am not aware of a control panel area for changing this.
     
  6. outofcontrol

    outofcontrol Member

    Joined:
    May 18, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Montreal
    As far as I know I am pretty current. The server is only a couple of weeks old. This is what the control panel says:

    cPanel 11.24.4-S35075 - WHM 11.24.2 - X 3.9
    REDHAT Enterprise 5.3 i686 standard on myserver
     
  7. PlatinumServerM

    PlatinumServerM Well-Known Member
    PartnerNOC

    Joined:
    Jul 10, 2005
    Messages:
    397
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    New Jersey, USA
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page