Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Where is the server-wide SpamAssassin config file?

Discussion in 'General Discussion' started by erick_paper, Feb 7, 2008.

  1. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    166
    It used to be in

    but those rules are not functional anymore. Any other ideas? Thanks!
     
  2. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    166
    I'd appreciate any info on this. How can I setup the global SA configs? Thanks!
     
  3. LBJ

    LBJ Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    78
    Likes Received:
    2
    Trophy Points:
    158
    We load our rules into /etc/mail/spamassassin/local.cf and it picks them up just fine.

    I just ran an extra test now on two servers and it's definitely still a goer.

    WHM 11.15.0 cPanel 11.18.0-S20595
    REDHAT Enterprise 4 i686 on standard - WHM X v3.1.0

    WHM 11.15.0 cPanel 11.18.0-S20595
    CENTOS Enterprise 4.6 i686 on standard - WHM X v3.1.0

    Remember to restart exim of course.
     
  4. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    166
    Well it's not working for me.

    For example, I have "required_score" set at 5, and my own scores for several tests. But the incoming email headers show a required_score of 2.5 and different scores. What gives? How can I debug this? Exim has been started many times.
     
  5. LBJ

    LBJ Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    78
    Likes Received:
    2
    Trophy Points:
    158
    Also remember that the global rules have a lower priority to the local rules at /home/*/.spamassassin/user_prefs

    Are you sure you're not overriding the values locally prior to your test?
     
  6. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    166
    In WHM there is a setting:

    WHen I disable this, it is supposed to look at /home/.../user_prefs file, but it doesn't. WHen I disable that option, the SA just comes in without ANY checks at all! So all the spam comes in. So I have enabled that option. But where this is picking up the "global conf" is beyond me. It is certainly not coming from /etc/...spamassassin/local.conf.

    Any other ideas?
     
  7. velda

    velda Well-Known Member

    Joined:
    Aug 24, 2005
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Utah
    Did you get any help with this? I can't seem to get one of my servers to pay attention to the local.cf file either. I want it to rewrite header information.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice