The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Where to add host headers

Discussion in 'Bind / DNS / Nameserver Issues' started by lemore, Nov 22, 2015.

  1. lemore

    lemore Registered

    Joined:
    Nov 22, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    I'm moving my hosted website's to my own VPS with Cpanel/WHM.
    Because my website is still live on the old host, i've added beta.newsite.com in the DNS on the old host (a-record to new host IP). Then i've setup the website on the new host, but how can i direct the beta.newsite.com to the correct NEW site in WHM/Cpanel on my own VPS host/ip?

    I tried the domain tools of Cpanel but i can't get that to work.
    Sub domains look the way, but then i have to choose a document root, but that just has to be the domain root, and if i try that it gives me the error: You do not have permission to create subdomains of the server’s hostname.

    What am i doing wrong?
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    go to tweak settings on your VPS server
    "Allow resellers to create accounts with subdomains of the server’s hostname."
    and check on
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    In addition to the previous post, please also ensure that your server's hostname does not match the actual domain name of the account. Instead, ensure it's something such as "server.domain.com".

    Thank you.
     
Loading...

Share This Page