Which version of ionCube is supported with cPanel 11.34?

ged75

Registered
Jan 22, 2013
4
0
1
cPanel Access Level
Reseller Owner
Hi,

I am trying to create a website, but the server must have at least ionCube v4 installed.

This is the error I am receiving:

"Loader Installed

The ionCube Loader version 3.3.20 for PHP 5.3 is already installed but it is an old version. It is recommended that the Loader be upgraded to the latest version if possible.

The installed version of the Loader cannot run files produced by the most recent ionCube Encoder. You will need a version 4 ionCube Loader to run such files."

I contact my hosting provider, who has WHM and cPanel 11.34 installed.

Their response was:

"At the moment, ionCube 3 is the default install with cPanel - until that supports version 4, we won't be able to offer that i'm afraid."

Is this correct? I see people on the cPanel forums discussing ionCube v4, so I am confused :confused:
 

Infopro

Well-Known Member
May 20, 2003
17,113
507
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
[root /]# php -v
PHP 5.3.20 (cli) (built: Jan 8 2013 08:48:45)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd.
with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH
Your host is mistaken.

What script are you trying to install, just curious.
 

ged75

Registered
Jan 22, 2013
4
0
1
cPanel Access Level
Reseller Owner
Thanks for your replies :)

I am trying to install 'Profits Theme' - a plugin for Wordpress

So where do I go from here? The plugin won't work because it shows the above error, and my hosts say there's nothing they can do about it because it's a cPanel issue :eek:
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
23
143
Houston, TX
cPanel Access Level
Root Administrator
You can ask your host to uninstall, then reinstall, ionCube Loader using /scripts/phpextensionmgr. What may have happened, is your host installed ionCube Loader some time ago, and since that time we have updated the version we distribute. They do not need to run EasyApache to uninstall and then install it, but you as a reseller do not have access to run /scripts/phpextensionmgr.

If they still insist that they cannot install ionCube Loader 4.x.x, ask them to contact us on your behalf. We will then be able to help them update it.
 

ged75

Registered
Jan 22, 2013
4
0
1
cPanel Access Level
Reseller Owner
Thanks Jared. I had a response from them:

"Thanks for that. It's not appearing in the normal logs within WHM as being possible and we'll note this for the next rebuild.

Unfortunately though we still can't roll this out straight away. We need to ensure this will not affect other users and will need to rebuild our own PHP to use it - we don't use the cPanel PHP binary."

Looks like I may have to find another solution! :cool: