nootkan

Well-Known Member
Oct 25, 2006
146
9
168
I just purchased a plugin that requires ioncube to be loaded. I went into easyapache 3 to add it but there are two options: ioncube 5 and ioncube 4. When I click on the more info button I can't see which option is the one for my server. Which option is the correct one for php 5.6.29 and apache 2.4.25?
 

nootkan

Well-Known Member
Oct 25, 2006
146
9
168
I can't update to easy apache4 just yet. I have to wait a few months (than I migrate to a new server) so I need to set up the server this way for now. Guess I should have explained why I am using easyapache3. So all other issues aside, which option is the right one for my situation?
 

AndyB78

Well-Known Member
Oct 7, 2003
80
2
158
Romania
cPanel Access Level
Root Administrator
Sorry to hijack this thread towards EA4 but in case we already have EA4, which version of ionCube is recommended? 6 is said to be experimental (some kind of beta?). And if 6 is experimental, how is v. 10? Anyway, which is recommended?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Sorry to hijack this thread towards EA4 but in case we already have EA4, which version of ionCube is recommended? 6 is said to be experimental (some kind of beta?). And if 6 is experimental, how is v. 10? Anyway, which is recommended?
Hi @AndyB78,

We provide a table on the document below with the IonCube loader versions available for each PHP version in EasyApache 4:

PHP Options - EasyApache 4 - cPanel Documentation

ionCube Loader 10 is available for PHP versions 7.1 and newer. You can only use ionCube 6 with PHP version 7.0 or earlier.

Thank you.