The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Which version of PHP should I use

Discussion in 'General Discussion' started by hardjoko, Oct 15, 2005.

  1. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Should I upgrade to 4.4 or 5.1?
     
  2. pshepperd

    pshepperd Well-Known Member

    Joined:
    Feb 12, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    FOUR aka (4)
     
  3. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    You mean, 4.4? What's the problem with 5.1 or 5.2?

    Thanks,
     
  4. pshepperd

    pshepperd Well-Known Member

    Joined:
    Feb 12, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    you can use 5+ you asked for my opinion which is 4.4, easier to support. If its just you on the server and your not supporting lots of clients use whichever you want.
     
  5. Gareth

    Gareth Well-Known Member

    Joined:
    Feb 11, 2004
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Isle of Anglesey, UK
    Not every php script out there currently fully supports php5.

    Then you have the problem that not all your clients (assuming it's not just for your own use) might not be using the latest versions.

    If you have other users on the server you need to ensure that they are not going to be affected by the change.
     
  6. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    I am the only one that use it

    I am the only one using the server. What scripts don't run on 5.2? What's the advantage of 5.2 over 4.4?
     
  7. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    You need to research that yourself. Go to Php Web site and study the advantages of using each release. Remember, using a program and related release is a matter of personal preference and what suits your needs, personally and technically.
     
  8. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    4.3.11. You cant go wrong.
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, yes, you can, since it contains bugs and vulnerabilities. That's why v4.4.0 came out. I too would recommend v4.4.0 unless you have a pressing need for v5, then go for that.
     
  10. DDT

    DDT Active Member

    Joined:
    Dec 10, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Yes, well, kind-of duh...
    Clients are clamoring for 5.1.
    I could have got a pre introduction special price to the support ticket-knowledgebase module for my order cart but it REQUIRED 5+
    And last but not least I thought I read here that 5.1 compatibility was an impending release with cPanel a couple of months ago so I have a lower-end server sitting idly by (still costs money) because my largest account DOES have an old php site that surely will have backward compatibility problems with the MySQL4.1 PHP5+ and with the supposed stability and other improvements to 5.1 they do not want to pay for a lot of expensive programming only to need more if 5.1 is different. So I have a partially there (but not functional copy of their site) I am paying for a server for, so their programmer could do compatibility work in a "non-live" environment IF it had 5.1. Just an unneeded expense for over 2 months now. I would drop it, but as sure as I did 5.1 and Apache 2 compatibility would be released and I'd have to set up another one.

    Other than that I will say we have had several sales calls that wanted to know if we were running 5+ and in EVERY case where a potential customer asked if we were running 5+ not one really needed it as of now. It's like another post said, everybody wants the "latest thing" even if they don't know why. On our production units...I agree, it's not broke, we are not fixing it as of now.

    However as mentioned in another thread I'd like to see Apache 2 and 5.1 compatibility, in my case for this "non-production" server so I could start seeing what we might run into. With new versions of MySQL, Apache, and PHP 5.1 being the current releases from them it's only time before customers start demanding them. Change is inevitable to these versions so for me it would be nice to be "test driving" all the new versions so I could see what we are going to run into on our production machines (and prepare for support issues etc.) :cool:
     
Loading...

Share This Page