The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM 11 Issue with Service Status

Discussion in 'General Discussion' started by Tina, Jun 21, 2007.

  1. Tina

    Tina Well-Known Member

    Joined:
    Jan 27, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    WHM >> Server Status >> Service Status

    cpsrvd up
    lfd up
    Server Load 0.00 (4 cpus)
    Memory Used x.x %
    Swap Used x.x %
    Disk /dev/sda1 (/) x.x %

    That's it. Can not see HTTP, EXIM, POP, NAMED, MYSQL etc....


    Brand new machine:
    WHM 11.1.0 cPanel 11.4.19-C14378
    CENTOS Enterprise 4.5 i686 - WHM X v3.1.0


    Transferring accounts from:
    WHM 10.8.0 cPanel 10.9.1-S14304
    CentOS 3.1 i686 - WHM X v3.1.0




    ~tina
     
  2. _Sam_

    _Sam_ Well-Known Member

    Joined:
    Feb 24, 2007
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    6
    have you ticked them in service manager?
     
  3. Tina

    Tina Well-Known Member

    Joined:
    Jan 27, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Hi Sam,

    Yes, I just checked and they are all double-checked in Service Manager.

    ~tina
     
  4. fcitrolo

    fcitrolo Active Member

    Joined:
    Dec 31, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    We have been having the same problem which started two nights ago.

    This is happening on three different servers.

    Two running:
    WHM 11.2.0 cPanel 11.6.0-R15076
    CENTOS Enterprise 4.5 i686 - WHM X v3.1.0

    The other:
    WHM 11.2.0 cPanel 11.8.0-C15921
    FEDORA 5 i686 - WHM X v3.1.0

    Many of the service features are double checked but only these are showing under service status:

    Server Load x.xx (2 cpus)
    Memory Used xx.x %
    Swap Used x.xx %
    Disk /dev/md1 (/tmp) x %
    Disk /dev/md2 (/boot) x %
    Disk /dev/md0 (/) x %

    Anyone else having this problem? And how do we fix it?:confused:
     
  5. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    Go into the Service manager and click save to be sure the settings are saved properly.

    Also may want to restart chksrvd (/etc/init.d/chksrvd restart) to reload the config.

    If this doesn't resolve it, please submit a ticket so we can look a little further into this.
     
  6. AussieHQ-Shaun

    AussieHQ-Shaun Registered
    PartnerNOC

    Joined:
    Oct 20, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    We had the same problem on servers of ours that auto update.

    Two nights ago all the services disappeared from the service status page, and chkservd was not monitoring them correctly.

    After last night's updates they're all back.
     
  7. cix

    cix Well-Known Member

    Joined:
    Nov 6, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Same problem

    We are with the same problem. Since two nights, the cpanel updates brokes chkservd even with the monitor boxes ticked. But we have many servers with the same problem yet, and we cant check on many servers to see if ALL are with the problem.

    We need a better solution.
     
  8. cix

    cix Well-Known Member

    Joined:
    Nov 6, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Im renting from Layeredtech, where can I open the ticket?
     
  9. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    Can you open a ticket with information from a server that is experiencing this issue so we can look further into this?
     
  10. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    It's probably best to submit a ticket with LayeredTech and ask them to relay the information to us in a support ticket, that way it follows the correct channels.
     
  11. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    It looks like an update then a manual restart of chksrvd resolves this.

    The update may not be needed, however I recommend running '/scripts/upcp --force' then restart chksrvd using '/etc/init.d/chksrvd restart' and the services should reappear.
     
  12. cix

    cix Well-Known Member

    Joined:
    Nov 6, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Hello,
    I did exactly what you suggest on another server with the problem, but didnt works.


    Another thing I saw is many servers that I´m trying to upcp --force I receive this message:

    [root@srv01 ~]# /scripts/upcp --force; /etc/init.d/chkservd restart

    cPanel Update (upcp) is already running. Please wait for the previous upcp to complete, or kill off all upcp processes and try again. You may wish to use '--force'
     
    #12 cix, Aug 10, 2007
    Last edited: Aug 10, 2007
  13. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    Run:
    Code:
    ps aux | grep Update
    Kill the reported Update processes

    Then run:
    Code:
    /scripts/upcp --force
    Go into Service Manager, click save, then run:
    Code:
    /etc/init.d/chkservd restart
    Try this method. Seems to resolve it on all servers i've tested with.
     
    #13 ToddShipway, Aug 10, 2007
    Last edited: Aug 10, 2007
  14. cix

    cix Well-Known Member

    Joined:
    Nov 6, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Ok,

    This part is essential to fix the problem 'Go into service manager and save!'

    Code:
    /etc/init.d/chksrvd restart
    I guess you mean chkservd, as chksrvd doesnt exists.

    Thanks
     
  15. ToddShipway

    ToddShipway Well-Known Member

    Joined:
    Nov 13, 2006
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    Yes, 'chkservd' is the correct service.
     
  16. petfut

    petfut Well-Known Member

    Joined:
    Feb 14, 2005
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    I had the same problem, it was because automatic upcp hung, killing it and running forced did the trick. Check also that your exim is working, I had problems with that too.
     
  17. cix

    cix Well-Known Member

    Joined:
    Nov 6, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Yes, exactly. This was the issue (i got many servers with upcp freezed) and I need to kill and run with --force parameter.
     
  18. chaloupe

    chaloupe Well-Known Member

    Joined:
    Mar 17, 2006
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dieppe, NB, Canada
    It did work for me also on two different server.

    Should Automatic update of cPanel be on:

    STABLE tree
    RELEASE tree or
    CURRENT tree?
     
  19. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The default is RELEASE. Current is a little less stable, but still production-worthy and is the first production-worthy build to receive new features (once they've graduated from our EDGE build). STABLE is more stable than RELEASE, rarely receives updates (relatively speaking) and is the last to receive any new features. As a result, it tends to be a little behind the curve in functionality in exchange for software stability.
     
Loading...

Share This Page