WHM 5/6 slow ftp upload timesout

eva2000

Well-Known Member
Aug 14, 2001
339
15
318
Brisbane, Australia
cPanel Access Level
Root Administrator
Twitter
Up uptil a week ago, everything was fine using latest at that time WHM 5.x with proftpd 1.2.4 but this week i decided to change over from normal FTP connections to Secure FTP connections via cuteftp pro 2.0

at first it worked, then now whenever i upload a small or large file via sftp or regular ftp, the transfer timesout :(

i did a traceroute from my pc to my server it it all looks fine no packet loss at all.....

how can i diagnose a slow ftp uploading problem ?

top part of my /etc/proftpd.conf file contains

Code:
# This is a basic ProFTPD configuration file (rename it to 
DisplayConnect /etc/issue.net
DisplayConnect /etc/issue.net
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                      "ProFTPD"
AuthUserFile /etc/proftpd/passwd.vhosts
LogFormat BytesLog "%b"
ServerType                      standalone
DeferWelcome                    off
DefaultServer                   on
DefaultRoot ~ !wheel

TimeoutLogin 1800
TimeoutIdle 1800
TimeoutNoTransfer 1800
TimeoutStalled 7800

# Port 21 is the standard FTP port.
Port                            21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

# Set the user and group that the server normally runs at.
User                            nobody
Group proftpd

# Normally, we want files to be overwriteable.
<Directory />
  AllowOverwrite                on
</Directory>
 

Slav

Well-Known Member
Oct 28, 2002
144
0
166
Hi htere i noticed ot have the same problem on a new server with cpanel 6, My system ad,in has looked at he issue and he cannot see whats causing it either.
 

Saeed

Active Member
Feb 20, 2003
34
0
156
Hello,

We're having the same problem. The connection speed is just fine, but uploads timeout. Normally (even yesterday) I could upload files to the server with speed around 50-70kb/s but today when I tried to upload, the speed started at about 20kb/s and slowly went down until reaching 0kb/s and stopping in the middle of the upload! I've ran traceroutes and even checked /etc/resolv.conf and everything seems to be just fine.

Any ideas?

:confused:
 

Slav

Well-Known Member
Oct 28, 2002
144
0
166
Yeha still not solved it here there is jsut nothing worng its only one isop i have issues with. even tohught i have 2 isp going through the same carrier.. its so weird as i dont have this issue onthe other server..... Its jsut one... It iwll start upping then sjust drop to 0k as you have and thats it lol