Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM 62 PHP-FPM Config

Discussion in 'EasyApache' started by Steve Paganelli, Jan 15, 2017.

  1. Steve Paganelli

    Joined:
    Apr 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Utah
    cPanel Access Level:
    Root Administrator
    Just got PHP-FPM working with FGID using Easyapache 4. Huge performance improvements.

    Just having an issue getting PHP-FPM to auto set config files in WHM 62 using Multi PHP Manager. Documentation says when I enable it by manually selecting the PHP version, 7 in this case. it should create a file at the following location.

    /etc/apache2/conf.d/userdata/std/2_4/<useraccount>/<vhost>

    However Currently I have to manually create these files for each domain using the version 58 instructions. What am I missing?

    Also when I change the Pool options and hit save it just gets stuck updating..
     
  2. ElviCities

    ElviCities Member

    Joined:
    Aug 9, 2012
    Messages:
    20
    Likes Received:
    6
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sorry to say I don't have any help to offer. Other than, I'm also having the same issue with the pool options not saving, and the circle just spinning forever.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello Steve,

    Could you verify which specific documentation URL you are following?

    Internal case CPANEL-10834 addresses an issue where saving FPM pool values within MultiPHP Manager fails in cPanel version 62. I'll update this thread once we publish the resolution.

    Thank you.
     
  4. Steve Paganelli

    Joined:
    Apr 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Utah
    cPanel Access Level:
    Root Administrator
  5. Steve Paganelli

    Joined:
    Apr 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Utah
    cPanel Access Level:
    Root Administrator
    cPanelMichael, it looks like your internal case has been fixed, and I can confirm I am able to save the Pool options now.

    However, the issue of the config files being autogenerated as shown in your documentation is still not occurring. Currently, to enable PHP-FPM I have to manually create the config files as noted in my first post.

    Is this a misunderstanding or a bug?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, the resolution stemming from internal case CPANEL-10834 was published in cPanel version 62.0.5:

    Fixed case CPANEL-10834: Fix saving FPM pool values within MultiPHP Manager.


    The paths you are looking for are documented at:

    PHP-FPM Code and FileSystem Layout for EasyApache 4 - Documentation - cPanel Documentation

    Any PHP-FPM configuration files that were manually created prior to the official PHP-FPM support offered in cPanel version 60 should be manually removed per the instructions at:

    Configure or Disable PHP-FPM with User Pools for EasyApache 4 - cPanel Knowledge Base - cPanel Documentation

    Here are some commands that will help with finding accounts with PHP-FPM enabled via the manual steps in cPanel version 58:

    Code:
    find /etc/apache2/conf.d/userdata/std/2_4/*/* -type f -name fpm.conf
    find /etc/apache2/conf.d/userdata/ssl/2_4/*/* -type f -name fpm.conf
    Thank you.
     
  7. Steve Paganelli

    Joined:
    Apr 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Utah
    cPanel Access Level:
    Root Administrator
    So if I remove those manually added configs, then PHP-FPM when enabled in the MultiPHP manager will work?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Yes, it should then work as expected.

    Thank you.
     
  9. Steve Paganelli

    Joined:
    Apr 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Utah
    cPanel Access Level:
    Root Administrator
    I removed the .conf files as outlined in the provided link and was able to revert it off PHP-FPM. then I went in to PHP Multi manager and enabled FPM for an account and saved then restarted PHP-FPM but that account did not switch to PHP-FPM.

    this is what it shows in phpinfo()

    Server: API CGI/FastCGI

    it should show PHP FPM

    Any ideas?
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello Steve,

    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here and we will update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page