The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM 9.1.0 cPanel 9.1.0-R72 Upgrade Fix

Discussion in 'General Discussion' started by matthewdavis, Mar 12, 2004.

  1. matthewdavis

    matthewdavis Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NC, USA
    Running the following commands will get your system back to working:

    rm -f /usr/local/cpanel/cpanel
    /scripts/installgd
    /scripts/cleanmd5
    /scripts/upcp
     
  2. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    this really work?

    Hi man, this really work?... please tell me... I try all the things... but no fix yet... and I don't want more problems... really this is a BAD DAY:(
     
  3. greengiant

    greengiant Well-Known Member

    Joined:
    Aug 31, 2003
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    I posted that fix in a few other forums, yes it seems to work.
     
  4. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    OH YES!!!!!!!

    OH YEAH!

    THIS FIX REALLY WORKS!!!! THANKS GUYS!!!!

    :D
     
  5. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    Maybe the ADMINS need to put this post in both support forums and with STICKY... this fix is the solution for all the world...:p
     
  6. davidnist

    davidnist Registered

    Joined:
    Mar 3, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Anybody try this on Redhat 9.0?

    I've run this over and over, but am still having the same problem:

    execvp No such file or directory.

    Thanks for any help in advance.
     
  7. ronowicker

    ronowicker Member

    Joined:
    Aug 3, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Thank You Thank You Thank You davidnist!!!!!

    Maybe CPANEL needs a new support person! Then again, nevermind, we need someone outside of their org to come up with the fix when they screw up.

    Thanks again...I can go home now!
     
  8. matthewdavis

    matthewdavis Well-Known Member

    Joined:
    Jun 26, 2003
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NC, USA
    Confirmed on Redhat 8, 9 & Enterprise 3.
     
  9. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Anyone notice mail is stuck in "q" and won't get sent out to normal e-mail accounts?
     
  10. davidnist

    davidnist Registered

    Joined:
    Mar 3, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the confirmation

    Still not working on my Redhat 9.0 box. I've gone through the above fix 3 times. I found in an earlier post one gentleman had to run it 6 times before it fixed his problem.

    Any other thoughts out there?
     
  11. takeover

    takeover Member

    Joined:
    Apr 29, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    thank you.
     
  12. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Re: Thanks for the confirmation


    That was me, but it seems, as my clients just notified me, all mail is getting stuck in "q" and wont delivered.

    What now?
     
  13. cyc

    cyc Member

    Joined:
    Feb 18, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for that it work nice!

    cheers
     
  14. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    You think it works but watch your mail "q". It'll hold your mail and not deliver anything.

    ticket#42837
     
    #14 XPerties, Mar 12, 2004
    Last edited: Mar 12, 2004
  15. davidnist

    davidnist Registered

    Joined:
    Mar 3, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Still not working with my Redhat 9.0 box

    Here's the complete error after I completed the above fix:

    rsync: getaddrinfo: rsync.cpanel.net 873: Temporary failure in name resolution rsync error: error in socket IO (code 10) at clientserver.c(83)
    Bad arg length for socket ::pack_sockaddr_in, length is 0, should be at /usr/lib/perl5/5.8.1/i386-linux/Socket.pm line 373.

    (whew!)

    Any help would be greatly appreciated.

    I'm not even getting as far as Xperties.
     
    #15 davidnist, Mar 12, 2004
    Last edited: Mar 12, 2004
  16. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    This worked thank you very much, your a life saver!!
     
  17. NiteStalker22

    NiteStalker22 Active Member

    Joined:
    May 13, 2002
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Nope ..

    Doesn't work at all on Red Hat Linux release 7.3 (Valhalla) ..

    I get the error about the missing execvp thingy too .... 'No such file or directory' ..... whatever; would be nice if it would say exactly WHAT is missing ......... *sigh*


    ..and the rsync is all screwed up as well ...

    md5sum mismatch (actual: ) (expected: baca5a2f6b26d8398041172cc82d8c4e)
    Download Failed... trying again..
    Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/cpanel/base/frontend/monsoon/mainicons/cpanel.gif.bz2..
    ..100%......Done
    bzip2: Can't open input file /usr/local/cpanel/./base/frontend/monsoon/mainicons/cpanel.gif-cpanelsync.bz2: No
    such file or directory.
    md5sum mismatch (actual: ) (expected: baca5a2f6b26d8398041172cc82d8c4e)
    Download Failed... trying again..
    Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/cpanel/base/frontend/monsoon/mainicons/cpanel.gif....10
    0%......Done
    md5sum mismatch (actual: ) (expected: baca5a2f6b26d8398041172cc82d8c4e)
    Download Failed... trying again..


    Y'all really dun it this time ... even the unsuspension on another system doesn't work... it just hangs after the first few lines. Whatever.
     
  18. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    problems continues

    Hey guys!!

    I post something about the email Q fix... but man...

    I TRY TO SEND THE Q MAIL or EMAILS AND NOTHING HAPPEN!!! the emails don't go to the destinatary... uffff

    Any one fixed the Q mail problem???? I think that was fixed, but I try to send email to other people outside of my hosted domains... and NOTHING..... the emails get in Q and when I try to send the Q emails, says "COMPLETE"... but I load the queue again and all the emails appears again.... PLEASE HELP!!!! NEED TO FIX IPTABLES?????? or something?? please If one get all working FINE PLEASE LET US NOW!!!!

    :(
     
  19. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Ive have posted this 4 times on the forums.....told everyone this would start.

    So far I have this issue on 2 servers and the Q keeps getting biggier and bigger.

    Still waiting on cpanel support.
     
  20. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    Yeah man... this is really a BIG BIG BIG AND FAT PROBLEM... we need CPANEL SUPPORT!!! We can't wait more hours... the domains and clients need answers!:mad:
     
Loading...

Share This Page