mtindor

Well-Known Member
Sep 14, 2004
1,378
69
178
inside a catfish
cPanel Access Level
Root Administrator
I watched the video put out by cPanel and available about installing NGINX (not NGINX standalone) on WHM 94. The cPanel guy was logged into a WHM 96 (well WHM 95.xxx) server but showing steps on how to do it on WHM 94. he then referenced CLI scripts available in WHM 94 to manage.

Here is what I did:

1. Logged into WHM
2. Navigated to EasyApache4
3. Clicked Customize next to my profiel
4. Navigated to Additional Packages
5. Selected NGINX
6. Saved the profile
7. Provisioned

There were no errors. It indicated that it had installed NGINX (and rpm -qa verified it was installed)
1. It didn't cause Apache to switch ports and have nginx run on 80/443 (in fact, nginx wasn't running it all post provisioning)
2. /scripts/ea-nginx or /usr/local/cpanel/scripts/ea-nginx did not exist (despite the guy saying CLI scripts are available in WHM94

So [I guess fortunately] it did not butcher my system. But it wasn't running and no ports were changed. I followed the guys' instructions.

So, I went back into EasyApache4 and went and provisioned my previous profile (without NGINX) and fortunately it removed the packages and did not obliterate any apache configuration.

Is it me, or is this not-ready-for-primetime on WHM 94 despite what the guys in the video said?

Mike


EasyApache - Customize Profile - Additional Packages - NginX
- click next
- provision
 

cPanelAdam

Product Owner (EasyApache)
Staff member
Apr 19, 2004
13
5
228
Houston
cPanel Access Level
Root Administrator
Hey Mike!

I'm "The cPanel guy" from the video! Can you tell me a little more about your system? Are you running CentOS or CloudLinux?

Thanks!!

Adam
 

mtindor

Well-Known Member
Sep 14, 2004
1,378
69
178
inside a catfish
cPanel Access Level
Root Administrator
Hey Mike!

I'm "The cPanel guy" from the video! Can you tell me a little more about your system? Are you running CentOS or CloudLinux?

Thanks!!

Adam
Hi Adam,

This particular system is CloudLinux 6 ELS, WHM 94, Not sure what else you'd like to know. If you are interested, just shoot me an email @gmail

Sorry for not referencing your specific name. I didn't have the video in front of me when I posted and couldn't remember who was involved in the video.

Mike
 

mtindor

Well-Known Member
Sep 14, 2004
1,378
69
178
inside a catfish
cPanel Access Level
Root Administrator
No need to apologize. Let me spawn a test instance and check this out. The system I was using was CentOS 7.
Thanks, Adam. In retrospect, I should have included much more relevant info than I did.

I also am not using PHP-FPM for customer websites. It is/was my understanding that PHP-FPM was only required for NGINX standalone. Maybe I'm wrong about that, and maybe that has something to do about. I also have no Ruby-related stuff installed on this server, but I do see mention of the need for some Ruby stuff in cPanel docs related to NGINX.

Mike
 

cPanelAdam

Product Owner (EasyApache)
Staff member
Apr 19, 2004
13
5
228
Houston
cPanel Access Level
Root Administrator
So looking at this it looks like you're absolutely right. Here's the version of ea-nginx being shipped from cloudlinux

[[email protected] ~]# rpm -qa |grep ea-nginx
ea-nginx-1.15.9-1.el6.cloudlinux.x86_64
[[email protected] ~]#

and here's the latest version that cPanel is shipping.

[email protected]:~# rpm -qa |grep ea-nginx
ea-nginx-1.19.8-3.3.2.cpanel.x86_64
[email protected]:~#

I've created a case on our side for tracking and will be reaching out to CloudLinux to see if they can get the updated version out for CL6.

Thanks and sorry for the confusion!

Adam
 

cPanelAdam

Product Owner (EasyApache)
Staff member
Apr 19, 2004
13
5
228
Houston
cPanel Access Level
Root Administrator
Hey Mike,

I just heard back from CloudLinux. The newest version of ea-nginx is currently in their beta repository. I was able to confirm that it exists in that repository but it's failing to install, looks like some incompatibilities with passenger. CloudLinux is aware and they are working on it. Stay tuned!

Thanks,

Adam
 
  • Like
Reactions: mtindor and cPRex

dimtsef

Registered
Mar 31, 2021
4
1
3
greece
cPanel Access Level
Root Administrator
i am doing some tests aswel so i tried

yum install ea-nginx

but i got the error

Error: Transaction test error:
file /etc/apache2/conf.modules.d/passenger.conf from install of ea-ruby27-mod_passenger-1:6.0.6-6.el8.cloudlinux.1.x86_64 conflicts with file from package ea-apache24-mod-alt-passenger-5.3.7-13.el8.cloudlinux.x86_64

so what i did is i went to easyapache and disabled the passenger module. after that i rerun yum install ea-nginx with all the dep required and finaly i got nginx up and running.
 
  • Like
Reactions: Kholodny

Kholodny

Member
Nov 30, 2020
9
2
3
Moscow
cPanel Access Level
Root Administrator
Hello, guys!

nginx needs ea-ruby27-mod_passenger
CloudLinux Python, NodeJS and Ruby needs ea-apache24-mod-alt-passenger

if i replace ea-ruby27-mod_passenger by ea-apache24-mod-alt-passenger (rpm -e --justdb --nodeps ea-ruby27-mod_passenger and install ea-apache24-mod-alt-passenger) apache failed with error «Invalid command 'PassengerDisableHtaccess', perhaps misspelled or defined by a module not included in the server configuration»

So, i think cpanel and cloudlinux team needs to investigate this problem together. (cloudlinux support create task ID EA4D-270 for this problem)