The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM always pushing /webmail /cpanel etc to hostname?

Discussion in 'E-mail Discussions' started by OoteR, Jun 15, 2007.

  1. OoteR

    OoteR Member

    Joined:
    Jun 12, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I've got a rapidSSL cert on my domain (domain.com) but regardless of the settings in whm's tweak settings (Cpanel11) IE7 etc is receiving a certificate from host.domain.com when I try to access domain.com/Cpanel etc. I am pushing the user to use the SSL/TLS.

    When visiting /cpanel or /whm or /webmail WITHOUT SSL, you can choose to redirect to:
    set to: Origin Domain Name

    When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to:
    set to: Origin Domain Name

    What do I need to change to fix this? I don't want to have to buy another cert.. :/
     
    #1 OoteR, Jun 15, 2007
    Last edited: Jun 15, 2007
  2. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    hi,
    certificate are bound on the URL you purchase for,

    so if you are having a cert installed on hostname the cpanel has this option to re-direct users to hostname for SSL login else the certificate would not work on other URL on your server (domain1.com, domain2.com etc)

    mohit
     
  3. vinc_dc43

    vinc_dc43 Well-Known Member

    Joined:
    Jan 19, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    this was never the case before? was this changed just to avoid the nasty error message you get in the browser?
     
  4. OoteR

    OoteR Member

    Joined:
    Jun 12, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Yeah, I understand that the certificate is bound to the domain name (domain.com). My problem is that when someone tries to access domain.com/cpanel they are getting sent to SERVERNAME.domain.com and the cert doesn't work.

    I want to stop it from forwarding to the host.domain.com and just use domain.com. Is that possible?
     
Loading...

Share This Page