Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

WHM always start exim on port 26 !

Discussion in 'General Discussion' started by zella, Sep 14, 2005.

  1. zella

    zella Member

    Joined:
    Aug 5, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    When you use the following within whm :
    Service Configuration -> Service Manager

    and you make a "SAVE" with "exim on another port " DISABLED

    then in all cases WHM start a exim process on port 26 !

    Is there a way to avoid that ?

    For the moment i need to kill the process for port 26.

    Thanks

    WHM 10.6.0 cPanel 10.6.0-C197
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    166
    What makes you believe that Exim is running on port 26 as well as 25?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. zella

    zella Member

    Joined:
    Aug 5, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    When you check the processes running on the server, you can easily find that a exim process is running on port 26.

    See hereafter after a "save" with "exim on port 26" DISABLED

    5 S mailnull 4513 1 0 69 0 - 1780 do_sel Sep13 ? 00:00:00 /usr/sbin/exim -bd -q60m
    5 S mailnull 4521 1 0 69 0 - 1773 do_sel Sep13 ? 00:00:00 /usr/sbin/exim -tls-on-connect -bd -oX 465
    5 S mailnull 3177 1 0 69 0 - 1773 do_sel 18:01 ? 00:00:00 /usr/sbin/exim -oX 26 -bd

    The last line says that : exim is waiting on port 26 and i don't want that.(Disabled within WHM configuration !)

    Regards.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    I've noticed that actually. Must be a bug with the cPanel exim starter when you update the service manager. You should be able to have it start correctly by running:

    service exim restart
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice