The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Whm and Wordpress

Discussion in 'General Discussion' started by tzifman, Nov 24, 2014.

  1. tzifman

    tzifman Registered

    Joined:
    Nov 24, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello

    First of all sorry for my bad English but isnt my first language.

    I own a dedicated server that uses Whm. I installed approximately 30 wordpress in accounts. Suddenly i cant upgrade wordpress via Whm for users. Error message is:

    Site Software cPanel::Blogs::WordPress

    This is a cPanel packaged module. (v1.04)

    Website WordPress

    Requires MySQL 5 or newer.

    Could not prepare working directory: No such file or directory


    I used also wpremote.com application but again i am not able to upgrade wordpress. How can i disable wordpress update via Whm and to update them via wordpress administration?

    Thanks in advance
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    You are using old mysql and due to that you are getting this issues, You can directly login your wp-admin panel and try to update it, And update here if you are getting any other issues while upgrading wordpress
     
  3. tzifman

    tzifman Registered

    Joined:
    Nov 24, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for your reply. The problem is that in wp-admin i cant see any update
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    To ensure the application remains managed by cPanel, you can only upgrade using the links provided in the email, or via the "Site Software" option within cPanel. Anytime you manually upgrade or move an application through the application's administrative panel, or by uploading the files via FTP, it prevents cPanel from managing that application at any point in the future. Thus, you must remove the cPAddon data (it's stored in a YAML file) for the application you manually upgraded from the following directory:

    /home/username/.cpaddons/

    Thank you.
     
  5. tzifman

    tzifman Registered

    Joined:
    Nov 24, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for your answer. Unfortunatelly via Site Software option within cPanel i can see again the same error message:

    Could not prepare working directory: No such file or directory

    Do you mean to delete the yaml file? Because i did it in 2 sites but still i cant see any update in their Administration panel.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, you have to remove the YAML file if you have attempted to upgrade WordPress outside of the "Site Software" option in cPanel. Are you referring to the WordPress administration panel? Are you sure the installation isn't already updated? Have you checked with the WordPress support forums?

    Thank you.
     
  7. tzifman

    tzifman Registered

    Joined:
    Nov 24, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I removed yaml in some sites but again i am not able to upgrade Wordpress via Wordpress administration panel. Also there isnt the option to reinstall wordpress that should be there. Version is 3.9.1

    Please check screenshots:

    Here is a correct working wordpress. It has the reinstall wordpress option
    correct.jpg

    Here is a not working wordpress. Cant see any update and hasnt reinstall wordpress option
    wrong.jpg

    Here is the whole update screen. In bottom right there is the version 3.9.1
    wrong2.jpg

    I believe that cpanel in someway it changed some files in wordpress like update.php or something like this.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  9. 24x7ss

    24x7ss Well-Known Member

    Joined:
    Sep 30, 2014
    Messages:
    271
    Likes Received:
    16
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes Michael is right you can update wordpress manually. Just take the backup of your wp-config.php file and put it on the safe location. Also, before upgrading take db backup also. Then you can download wordpress and replace the files with new WP files and complete the process. This will fix your issue.
     
Loading...

Share This Page