Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

/whm blank

Discussion in 'General Discussion' started by wills, Nov 12, 2009.

  1. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    168
    My /whm interface is displaying a blank page. Does anyone know what I can do to troubleshoot the issue? Any pointers?
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,366
    Likes Received:
    6
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    What WHM version?

    Saw this problem with a recent Edge build which turned out to be a perl issue.

    Have you tried /scripts/checkperlmodules?
     
  3. camposomar

    camposomar Active Member
    PartnerNOC

    Joined:
    Mar 30, 2009
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Guadalajara
    /scripts/upcp --force
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,554
    Likes Received:
    9
    Trophy Points:
    168
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    This may or may not be related to a very brief issue that only affected a recent EDGE build, but is fixed as of build IDs 41106 and 41121 as seen in the following change log:
    cPanel - The Leading Control Panel - Change Log (#EDGE)
    Code:
    Edge 41121, 2009-11-11 12:15:18
    * Add support in Cpanel::Locale to fallback to a known language when an unknown language is specified for an account
    * Resolve problems enabling and disabling shell fork bomb protection under FreeBSD
    * Adjust handling of /etc/profile when enabling/disabling shell fork bomb protection
    * Adjust issue with command line processing in checkperlmodules that might prevent installation of Locales Perl module
    
    Edge 41106, 2009-11-11 02:13:11
    * Adjust logic to create symlinks to system installed Locales Perl module for cPanel/WHM binaries
    * Supply special environment variable needed to make SQL::Statement Perl module
    * Update /scripts/checkperlmodules to give a final report of which modules failed to install/update

    What is your full cPanel version number?
    Code:
    # cat /usr/local/cpanel/version && echo
    If EDGE or cPanel version 11.25, please try one of the following two methods via root SSH access:

    Method 1.) Ensure your EDGE build is up-to-date to automatically correct the issue as it is fixed in the latest build:
    Code:
    # /scripts/upcp --force
    Method 2.) Force an install of the Locales module from CPAN:
    Code:
    # cpan -f Locales
    # /scripts/checkperlmodules

    If the full version information indicates a build tree that is not EDGE, not cPanel version 11.25, or if the issue persists, please let us know what messages are being logged upon testing access to WHM; the following command can be used to monitor the error_log immediately prior to and during testing:
    Code:
    # tail -fvn0 /usr/local/cpanel/logs/error_log
    The key combination "Ctrl+C" may be used to end the "tail" process that was started for monitoring the log file.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 cPanelDon, Nov 12, 2009
    Last edited: Nov 12, 2009
  5. DragonflyWHD

    DragonflyWHD Registered

    Joined:
    Jul 18, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    I am having this same issue... im running freeBSD 7.2 and cp verision is 11.25.0-RELEASE_42400

    tail -fn0 /usr/local/cpanel/logs/error_log gives me the following error:

    open3: exec of /usr/local/cpanel/whostmgr/bin/whostmgr3 ./initial_setup_wizard1 failed at cpsrvd line 6089
    Internal Error: "GET /scripts3/initial_setup_wizard1 HTTP/1.1" open3: exec of /usr/local/cpanel/whostmgr/bin/whostmgr3 ./initial_setup_wizard1 failed at cpsrvd line 6089

    Any ideas?
     
  6. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,554
    Likes Received:
    9
    Trophy Points:
    168
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Via root SSH access what is the output of the following command?
    Code:
    # stat -x /usr/local/cpanel/whostmgr/bin/whostmgr3
    For reference, the stat option "-x" is only used to make the stat output on FreeBSD appear similar to stat output seen on Linux.

    If the file is missing it will be necessary to re-install the missing component by running a forced cPanel update; this may be performed using the following command via root SSH access:
    Code:
    # /scripts/upcp --force
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice