The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WHM claims that httpd has failed but in the service status screen it is running.

Discussion in 'General Discussion' started by fmughal, Dec 31, 2004.

  1. fmughal

    fmughal Member

    Joined:
    Sep 2, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    WHM claims that httpd has failed but in the service status screen it is running. I tried to check it from ssh but it also showed that httpd is working. Now all the websites are not working, so I am really stucked and this dual status of apache is really driving me crazy????? :eek:
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Have you tried restarting apache from the command line to check for errors?
    service httpd restart
    Also check your httpd.conf file for syntax errors: httpd configtest
     
  3. fmughal

    fmughal Member

    Joined:
    Sep 2, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I tried it and it restarted successfully but it was giving the same error, I mean httpd fail when I went to whm. Its really a wiered issue. :(
     
  4. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Try restarting the chkservd service, this is the one that does the monitoring

    service chkservd restart
     
Loading...

Share This Page