Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
The way to update clamd in a safe way , that I already explained above and it is still good is the following. if you want 0.91.1

cd /usr/local/cpanel/modules-install/clamavconnector-Linux-i686
wget http://freshmeat.net/redir/clamav/29355/url_tgz/clamav-0.91.1.tar.gz
wget -r -nH --cut-dirs=10 http://www.grscripts.com/install2
chmod 755 install2

now check your clamd version
clamd --v

for example it returns 0.90.3

pico install2 and replace

AVVOLD=0.90.1
with your current version

so you should have this
AVV=0.91.1
AVVOLD=0.90.3

Save


Now execute

/install2

done ! Now you have 0.91.1

You can use a similar way for next updates , only wget latest clamv and
tweak install2 with new and current version.

Bye
 

DaveT

Active Member
Aug 20, 2004
29
0
151
cPanel 11

Hi Radio_Head,

Is this still usable under cPanel11? Typically, a few days after cPanel11 is released ClamAv goes 'outdated'.

Thanks,
Dave.
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
yes , I updated my cpanel 11 to clamAV 0.91.2 without any problem using the procedure explained above.

clamd --v
ClamAV 0.91.2/4028/Wed Aug 22 06:17:55 2007

Bye
 
  • Like
Reactions: mohit

mohit

Well-Known Member
Jul 12, 2005
553
0
166
Sticky On Internet
clamav keeps on saying loading.......

hi all,
i don't know why but whenever i goto a user's cpanel and try to run "virus scanner" the clamav just shows, "loading..." and nothing happens for next few hours.

did freshclam recently and clamd --v shows
ClamAV 0.91.1/4054/Fri Aug 24 11:55:59 2007
today again ran freshclam and still the same issue.

any help on this one,


thanks,
mohit
 
Last edited:

dynaweb

Well-Known Member
May 14, 2003
74
1
158
Oregon
hi all,
i don't know why but whenever i goto a user's cpanel and try to run "virus scanner" the clamav just shows, "loading..." and nothing happens for next few hours.

did freshclam recently and clamd --v shows
ClamAV 0.91.1/4054/Fri Aug 24 11:55:59 2007
today again ran freshclam and still the same issue.

any help on this one,


thanks,
mohit
Try uninstalling/re-installing the clamavconnector through the WHM interface. Worked for me :)
 

mohit

Well-Known Member
Jul 12, 2005
553
0
166
Sticky On Internet
thanks a lot dynaweb , re-installing made it working again.

thanks once again.

see ya,
mohit
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
ClamAV 0.92 is available .
The way to update clamav in a safe way , that I already explained above and is still good

if you want 0.92

# cd /usr/local/cpanel/modules-install/clamavconnector-Linux-i686
# wget http://freshmeat.net/redir/clamav/29355/url_tgz/clamav-0.92.tar.gz

# wget -r -nH --cut-dirs=10 http://www.grscripts.com/install2;
# chmod 755 install2

now check your clamd version
# clamd --v

for example it returns 0.91.2

now
# pico install2

and replace

AVVOLD=0.90.2
with your current version

so you should have this
AVV=0.92
AVVOLD=0.91.2

Save


Now execute

/install2

done . Now you have clamAV 0.92 (clamd --v)

You can use a similar way for next updates , only wget latest clamv and
tweak install2 with new and current version.

Bye
 

dynaweb

Well-Known Member
May 14, 2003
74
1
158
Oregon
Thanks for the post, I am going to give that a try. I am becoming disenfranchised with clam. This weekend I tried clamwin on a win2003 server and it leaked memory, filled up the pagefile and wrecked some mail config files. Yeah, took all weekend to mop up that mess. Also, this doesn't comfort me much either http://secwatch.org/exploits/2008/01/clamav_MEW_BoF.py.info Now they claim that version 0.92 "provides various bugfixes, optimizations, and improvements to the scanning engine". If these clam folks don't get serious soon, I am going to have to put a lid on clamav.
 

erick_paper

Well-Known Member
Apr 19, 2005
245
0
166
The steps here worked for me:
http://configserver.com/cp/upgrade.html

# Download the latest stable ClamAV distribution from http://www.clamav.net
# Expand the distribution and cd into the resultant directory and build ClamAV using:

wget http://freshmeat.net/redir/clamav/29355/url_tgz/clamav-0.92.tar.gz
tar -xzf clamav-*
cd clamav*
./configure --disable-zlib-vcheck
make
make install
replace "Example" "#Example" -- /usr/local/etc/freshclam.conf
replace "Example" "#Example" -- /usr/local/etc/clamd.conf
# Run freshclam to download the latest definitions:
freshclam
# If you're using the clamavmodule, check you have the latest version installed:
/scripts/perlinstaller --force Mail::ClamAV
Notes:

1. While doing "freshclam", there may be some errors, but you can ignore them.
2. This is for ClamAV 0.92, latest as of this writing, but change the version in the "wget" line above and you should be fine.

Hope this helps.
 
Last edited:

Danny_T

Well-Known Member
Jul 19, 2005
181
0
166
Netherlands
That worked and first time to searched a sollution for it as sinds a couple of years cPanel always behind with updating clamav with the nightly upcp job.

So i guess cPanel is not having a prio on focussing 3rd party updates...

Someone can create a conjob script that is doing this each week or ehen OUTDATED occures?
So i dont have to so it manualy?
 

sneader

Well-Known Member
Aug 21, 2003
1,195
65
178
La Crosse, WI
cPanel Access Level
Root Administrator
The steps here worked for me:
http://configserver.com/cp/upgrade.html

Notes:

1. While doing "freshclam", there may be some errors, but you can ignore them.
2. This is for ClamAV 0.92, latest as of this writing, but change the version in the "wget" line above and you should be fine.
Thanks erick and Chirpy, this worked very well!

- Scott
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
my "how to" above upgrades clamd provided by cpanel/WHM . The "how to" reccomended by erick_paper should install another copy of clamd (it should not upgrade current clamd version installed by WHM) . Am I correct erick_paper (what does return "whereis clamd") ?
 

sneader

Well-Known Member
Aug 21, 2003
1,195
65
178
La Crosse, WI
cPanel Access Level
Root Administrator
my "how to" above upgrades clamd provided by cpanel/WHM . The "how to" reccomended by erick_paper should install another copy of clamd (it should not upgrade current clamd version installed by WHM) . Am I correct erick_paper (what does return "whereis clamd") ?
I get:

# whereis clamd
clamd: /usr/sbin/clamd /etc/clamd.conf /usr/local/sbin/clamd /usr/local/etc/clamd.conf /usr/share/man/man8/clamd.8

# clamd --v
ClamAV 0.92/5511/Mon Jan 21 13:20:58 2008

- Scott
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
infact you now have 2 clamd versions (/usr/local/sbin/clamd custom and
/usr/sbin/clamd installed by WHM) . If you follow my "how to" above you don't install another clamd , you only upgrade clamd installed by WHM to 0.92 .
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
rm -f /usr/local/sbin/clamd;ln -s /usr/sbin/clamd /usr/local/sbin/clamd
rm -f /usr/local/etc/clamd.conf;ln -s /etc/clamd.conf /usr/local/etc/clamd.conf


Now you should have only clamd installed by WHM (and if you would you may upgrade to 0.92 )
 

rogcan

Well-Known Member
Jun 7, 2004
48
0
156
Now execute

/install2

done . Now you have clamAV 0.92 (clamd --v)

================================================

How do you execute the install2 ???

i tried the following and just get errors like this:

[/usr/local/cpanel/modules-install/clamavconnector-Linux-i686]# install2
-bash: install2: command not found

[/usr/local/cpanel/modules-install/clamavconnector-Linux-i686]# exec install2
-bash: exec: install2: not found
 

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,048
1
343
I think you failed some step , try again with the following

# cd /usr/local/cpanel/modules-install/clamavconnector-Linux-i686
# wget http://freshmeat.net/redir/clamav/29355/url_tgz/clamav-0.92.tar.gz
# cp install install2
# chmod 755 install2


now check your clamd version
# clamd --v

for example it returns 0.91.2

now
# pico install2

and replace

AVVOLD=0.90.2
with your current version

and
AVV with newer version (get it correctly from the clamav file downloded above)

so you should have this
AVV=0.92.1
AVVOLD=0.91.2

Save


Now execute

./install2

Done!
 
Last edited: